1
$\begingroup$

So I'm trying to use maps while applying textures to produce a more realistic scene. The issue is my scene is producing too many fireflies. I've tried adjusting clamp settings but the fireflies are still there. I've also tried adjusting values in the node editor but it's till not working.

This is how I have setup my lighting: enter image description here Here's my node editor screen: enter image description here

The final image render: enter image description here

I've tried adjusting the roughness values of the glossy shader and the diffuse shader but the fireflies are still there.

$\endgroup$
  • 4
    $\begingroup$ Possible duplicate of How to reduce fireflies in Cycles? $\endgroup$ – bertmoog Jul 8 '17 at 22:43
  • 1
    $\begingroup$ @Michael images used as textures are not saved on the blend file unless you pack them (see this link) Without the textures the file makes no sense. Also don't make your question dependent on others downloading your file exclusively, write in detail what you've tried and show images of the relevant settings you've been playing with. To share files in this site please use blend-exchange.giantcowfilms.com $\endgroup$ – user1853 Jul 8 '17 at 23:26
  • $\begingroup$ @cegaton Thank you for the advice. I've edited the question accordingly. I know didn't about blend-exchange.giantcowfilms.com $\endgroup$ – Michael Jul 9 '17 at 9:47
  • $\begingroup$ @bertmoog I already checked that question. It didn't help $\endgroup$ – Michael Jul 9 '17 at 9:48
4
$\begingroup$

Cegaton advices are good to folow to help people to help you.

I've tried with my own textures and have the same fireflies.

In your specific case:

  • you've plug the normal in the Height slot, height is for bump map (grayscale images), with this I haven't got any fireflies at 32 samples.
  • it's better to have a mesh correctlly unwrap, apply the scale before unwraping and redo the unwrap.
  • too strong normal map or bump map can lead to fireflies
  • not really fireflies related but when trying to recreate realistic materials, never mix a diffuse and a glossy without a fresnel effect. Node Input--> Fresnel and plug it in the mix factor

General advice regarding fireflies:

  • Personnally the most important feature when using HDRi is to set the map resolution to at least 2048, but I prefer 4096 for a good base, personnally I never go under but I'm not so limited by graphic card memory.
    Go to properties tab--> world--> settings pannel--> map resolution.

  • An other fireflies killer and lighting killer if you don't set up corrctly, is the clamp direct in the properties tab--> sampling pannel.
    To set up correctly you need to determine what is th most powerfull ray that land in your scene and adjust the value to clamp only what necessary. A bit tricky. In most case without too much risk a value between 100 to 80 make the job without altering the lighting (if you don't see light sources).

Perhapse I'll edit my answer to give my tech if someone is interest.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.