18
$\begingroup$

I need to open .stl files with blender, without importing them!

In the properties of my .stl file, blender is set as "open with", but when I double click on the file it just opens blender as my preset user preference (without any objects). The same happens when I drag the file over the blender icon to open it that way.

Whats funny is that if I drag and drop the file over an older version of blender (2.49) then it opens the .stl file fine.

Any ideas?

Thanks

$\endgroup$
20
$\begingroup$

Assosiating STL with Blender no longer works, you have to use File -> Import -> STL now.

This is because STL used to be written in C and loaded the same way *.blend files were, but now its an addon.

Note, its possible to make a shell script or batch file which you can assosiate STL with, that calls blender with the addon, though this isnt completely straightforward and will require some small Python snippet to run the importer.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Okay, the problem is that I'm trying to open the STL file automatically from php via: exec("start /B cmd /k $blender -b C:\\xampp\\htdocs\\test.new\\upload\\$file -P C:\\xampp\\htdocs\\test.new\\newBlender\\getData.py"); But now I should call a separate python file from php and in that python file import the STL into blender, then run the python file that was originally called straight from php? $\endgroup$ – Alex Husarenko Apr 8 '14 at 9:39
  • $\begingroup$ Regarding command line args, see: blender.stackexchange.com/a/8405/55 $\endgroup$ – ideasman42 Apr 8 '14 at 10:27
  • $\begingroup$ Hi! cannot find "import -> STL" in the file menu under 2.76 of blender, has it been removed or is this an external addon? thanks $\endgroup$ – MicroMachine Feb 10 '16 at 20:34
  • $\begingroup$ You must have the add-on disabled, try reset factory settings. $\endgroup$ – ideasman42 Feb 11 '16 at 5:21

Not the answer you're looking for? Browse other questions tagged or ask your own question.