1
$\begingroup$

When text is displayed in front of other text, the background text does not display correctly through the transparent parts of the letter. It looks like there is a surrounding box around each individual character of the text where no other text is displayed. See the b example in the screenshot, where I marked the surrounding box.

However, this behavior seems to apply to text/text relationships only. Where I have text in front of cubes, the cube color shines through correctly.

All objects are real text objects, no images, not textures. The text objects themselves are not transparent, they are opaque. But I expect them to be, well, transparent in the holes of the letters (sorry, I'm a non-native English speaker, if you understand what I mean, you can edit this sentence).

Is this a bug which should be reported or can I influence this behavior somewhere?

Version info: Blender 2.70, downloaded
Render Engine: Blender Game
Download SSCCE .blend file

Open the SSCCE in Blender 2.70. Hover your mouse over the 3D viewport. Press P to start game engine. Move your mouse so that the two text objects overlap.

Screenshot

$\endgroup$
2
  • $\begingroup$ @Polosson: are there several game render engines? All items are real text objects, not images or textures. I am working on a blend file, but at the moment it contains personal data. $\endgroup$ Apr 8, 2014 at 11:11
  • $\begingroup$ See my comment in your resolution question. The problem is, that there are currently no alpha modes or depth sorting for text objects. It is better to use uv mapped planes. These are better integrated in the scene graph. $\endgroup$
    – user2859
    Apr 8, 2014 at 16:17

4 Answers 4

1
$\begingroup$

If only I could get more details as to what exactly you expect from the software, I might be able to answer your question right.

However, from you explanation, I replicated that, and I'm not seeing any problem.

My output per following your current explanation

What version of blender are you using? You built from source or downloaded from blender.org?

I just set my transparency to the desired value in the materials tab in the properties panel and all seem to go well.

By the way, I used the bge too.

$\endgroup$
3
  • $\begingroup$ I have uploaded a .blend file which reproduces the issue on my machine. Maybe you can have a look at that. $\endgroup$ Apr 8, 2014 at 12:57
  • $\begingroup$ Okay. I think I've seen what you're referring to. Will converting the text into mesh (press Alt + C) do the trick? I also didn't see the transparency applied to the text. Convert the text to mesh and work with it just like you wish. I think that'll be much more convenient since you're working in the BGE. $\endgroup$
    – KhoPhi
    Apr 8, 2014 at 13:27
  • $\begingroup$ There is no trancparency in that sense. It's just transparent in the holes of the letters. I cannot convert it into a mesh, because the text will be updated dynamically by a Python script to display some information. $\endgroup$ Apr 8, 2014 at 13:44
0
$\begingroup$

I"m on my tablet right now, so I can't look at the blend. I used to have a ton of issues with texts, but here's the main fix. Just change the text into an actual mesh(Alt+C > Mesh), then put the material with transparency. Though this will not work if you want your text to change, there is a long process. This way, the text will have more quality, and you can out transparency, just as any other object.

$\endgroup$
0
$\begingroup$

The game engine seems to convert your text objects to planes with a character texture automatically. Note that new Text objects I added to the scene were converted to a mesh instead which worked fine since the text borders were not defined by transparency. I couldn't figure out which setting caused the text-to-texture conversion, otherwise I would advise you to turn it off.
The problem the transparent textures introduce is that the objects need to be rendered back to front for the transparency to show correctly (see also my answer here). For normal meshes you could just add a material and set the 'Alpha Blend' mode in the material's 'Game Settings' to 'Alpha Sort'. Unfortunatly this seems not to work for your text objects, since they seem to not react to any material settings at all.

The only easy solution I found to this problem is to convert the text objects to a mesh by pressing [Alt+C] and selecting 'Mesh from Curve/Meta/Surf/Text'. This will also remove the resolution problem. Note that this will make your text uneditable, so you probably want to keep a copy of your original text somewhere (on a different layer perhaps).

$\endgroup$
0
$\begingroup$

I'm not sure if this is a bug or a limitation of the way the text is generated in Blender. Converting to mesh is OK but very messy for those wanting the convenience of text editing.

A work around below I am using might be better for some.

Just animate the TEXT you want in clear view in a particular scene a little in front of the TEXT2 interfering with the TEXT that is visible. Then it doesn't matter that TEXT2 behind is not truly transparent.

Don't forget to move the TEXT back to the old position when you make it transparent again, otherwise the different text images creep forward when used multiple times. It may sound clumsy, but usually involves just animating a single axis to move TXT forward, inserting one animation key, or two keys to set it in place for a longer time, then duplicate the first key to move it back again later in the sequence.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .