29
$\begingroup$

I accidentally opened too many menus (or windows) and I want to reset them to default. It is really annoying, and effecting my animation. Thanks

$\endgroup$
25
$\begingroup$

Info Header

The Info header is the header bar that contains the File menu option.

Each window in Blender has a header bar and the type of window is set by the first icon on the left-most side of every header.

For example, in this picture, the different windows are highlighted in yellow and the Window Type icon for each is highlighted in green:

enter image description here

In order to change any window from one type to another, just click on the Window Type icon and select the type of window you want to have. In your case, you will need to set one window to Info since it has the File menu option so you can restore the factory defaults by clicking: File > Load Factory Settings. Here is what the Info icon looks like:

enter image description here

NOTE: It is also possible to hide the header by dragging it's top edge down. This leaves a small grey tab with a + sign in it on the right-hand side of the window. Clicking on this + tab brings the header back into view:

enter image description here

You can read more about header bars here in the Blender Wiki.

Manually Rearranging Windows

However, you can also manually close windows or open new ones by dragging on the window splitter widgets (they look like a little ridged thumb grip) in the upper right and lower left corners of every window:

enter image description here

Here is a demonstration of how to drag the window splitter widgets to open and close different windows, as well as how to change these windows from one type of window to another by changing the Window Type icon:

enter image description here

You can learn more about how to manually arrange window frames the way you would like them here.

You can also check out the answers here and here.

$\endgroup$
  • 2
    $\begingroup$ Very long and probably correct article, but hard to see if it contains the answer to the question $\endgroup$ – Dims Dec 16 '16 at 19:44
10
$\begingroup$

While I can't see your layout to know exactly what to do there are a few options available that you may easily recover from.

  • If you have hidden the header of the info window you can unhide it by clicking the + button in the right hand side on the window.

  • (for 2.70 or later) If you have collapsed the menus you can still access them by clicking the little three bar icon in the header.

enter image description here

  • By right clicking the same icon you can un-collapse the menus.

enter image description here

  • (before 2.70) Instead of collapse menus we had a hide menus option that shows as a little + in a circle. Click it to un-hide the menus.

enter image description here

In the worst case scenario where the above doesn't help and you have saved the bad setup to your startup file you have a couple of options available.

  1. Press CtrlO or F1 to open a blend file. This should make the main menu visible where you can load factory settings. If not select a blend file to open ensuring the Load UI option is turned on. This will load the window layout from the file that you open and should give you access to the main menu.

  2. Worst case you may want to delete your startup.blend file to start from scratch. While there are three possible locations for the startup.blend you will most likely find it in the USER location. This wiki page explains all three locations for each OS.

$\endgroup$
  • 1
    $\begingroup$ My problem was that I added a new workspace that filled up the full width of the window. So on top I've got the menu from the workspace, not blender itself. Closing that workspace was not possible as I got many small ones below it. Finally F1 + Factory reset solved that problem. Thank you very much. $\endgroup$ – C4d Feb 21 '18 at 15:57
  • $\begingroup$ I would have selected this answer just for the "Load Factory Settings" $\endgroup$ – frank Mar 19 at 13:41
6
$\begingroup$

Its way too old, May be help full for some body

enter image description here

Its real easy - Save the file - close blender - Open blender - Open the file and un check the load UI on open dialog

As shown below: enter image description here

Result :

enter image description here

$\endgroup$
3
$\begingroup$

You can restore the factory defaults by clicking: File > Load Factory Settings.

Then set it as the default press CtrlU

$\endgroup$
  • $\begingroup$ Thanks, but my file menu is gone. Could you tell me how to find it? Thanks $\endgroup$ – user3046 Apr 7 '14 at 22:24
  • $\begingroup$ It's in the Info view. Just change any open view to an Info view. $\endgroup$ – Samoth Nov 18 '15 at 16:35
1
$\begingroup$

I found a solution to reset all Screen Layouts s in a project is to: -Save project -Create a new project -Load Factory Settings -File: Append: Your previous project -You delete the Scene -You have your Screen Layouts back

My Animation Screen Layout disappeared mysteriously and I could fix it with that. Hope help someone.

$\endgroup$
0
$\begingroup$

My right menu suddenly disappeard too. Only the Properties panel was visible. Even the menu on the bottom (timeline) was gone. I found out why.

If you press CtrlUp Arrow the menus will disappear and reappear. But at least I have them back now. :D

Hope this helps others too! Happy blending!

$\endgroup$

protected by cegaton Mar 1 '18 at 22:55

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.