I'm working on animating a person climbing a building for a school project. I have the rigged character and the model for the building, but the model for the character is far too large. I used the scale tool to scale it down to the proper size, then began to model. After I moved the first bone, what looks like a large blob appears under one of the character's feet. This disappears if I go into edit mode, but is visible in object or pose mode in both solid and rendered view. Any help would be appreciated.

  • $\begingroup$ Can you upload your blend file and also some screen shots so we can see just what you're experiencing, since this problem could be caused by many things. If you need a place to upload to, you can use PasteAll.org -- it's very easy to use: pasteall.org/blend $\endgroup$ Commented Apr 5, 2014 at 21:17
  • $\begingroup$ I found a model that worked better for what I needed anyways and I'm not having the problem anymore. I'm still interested as to what the problem is, though. I posted it to pasteall.org/blend/28205. The file name is error.blend. $\endgroup$
    – Skirata
    Commented Apr 5, 2014 at 21:54
  • $\begingroup$ If the answer below solved your problem, don't forget to click the "Solved" checkmark to let everyone know the question has been solved. :) $\endgroup$ Commented Apr 18, 2014 at 3:15

1 Answer 1


Apply Object Transformations When Rigging

The problem with the figure's foot is that the scale of the figure and the scale of the rig are not both equal. This can cause unusual behavior like what you experienced.

To prevent this from happening, whenever you are joining a rig to a mesh, you must first always apply their scales so the scales are both set to 1.

The reason for this is simple: when you import a figure, it will default to have a scale of 1. Also, when you add a rig, it too will default to a scale of 1.

However, almost always the figure and the rig will be different sizes, so you naturally will change the scale and maybe even the rotation of one or the other so they match up and the rig fits right inside the model.

This results in a difference of scale (and maybe rotation) of the rig and the model. In your file, the figure's scale is 1, but your metarig's scale has been reduced down to 0.195:

enter image description here

(You can see the scale of objects in the Properties panel, which can be opened with N)

This difference of scales becomes problematic when the rig is joined to the figure.

Therefore, whenever you finish scaling and/or rotating both your figure and your rig, you need to Apply Object Transformations to both the figure and the rig. When you are Applying Transformations, you can apply the location, rotation, and/or scale.

Here is how you do that, first for either the rig or the figure, then for the other:

  1. In Object mode, select either the rig or the figure
  2. Then use one of these methods to apply transformations:

    • 3D View Header -> Object -> Apply -> Rotation & Scale

    • CTRLA -> Apply Rotation & Scale

enter image description here

The main goal is to have the Rotation for both rig & figure set to 0 for X, Y & Z, and also to have the Scale for both be set to 1 on X, Y & Z.

Then your rig will work properly.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .