0
$\begingroup$

I use a heavily modified shortcuts for blender. I have set "select shortest path" to ctrl+right click and it has worked for a long time until today. I am not aware of changing anything recently but suddenly instead of "shortest path" the above shortcut does something weird:
-selects the shortest path
-makes all selected edges freestyle edges
-deselects all

Any idea what's happening?

$\endgroup$
6
  • $\begingroup$ That is quite localized situation. Obvisouly there is some conflict between these 2 actions, so search for the key binding for them both and see if there are some interesting details. $\endgroup$
    – Mr Zak
    Jul 8, 2017 at 13:21
  • $\begingroup$ I did an extensive search... freestyle edges are not assigned to anything. There are no conflicting bindings. Boggles my mind. $\endgroup$
    – CGDive
    Jul 9, 2017 at 13:14
  • $\begingroup$ That might be a bug but likely something with shortcuts as you wrote you use "heavily modified ones. Ctrl+Right Click is default setting for Pick Shortest Path so there's something else going on. Try opening Blender from the command line in debug mode, see blender.stackexchange.com/questions/21772/…, repeat actions with selecting that path and see what is logged in the console window, probably it will write something useful. Note also that Pick Shortest Path has options in the F6 menu, maybe they are changed. $\endgroup$
    – Mr Zak
    Jul 9, 2017 at 13:59
  • $\begingroup$ I found nothing pertaining to the problem in the console. Nevertheless I have edited my original question with all the warnings that show up in the console when I start blender. $\endgroup$
    – CGDive
    Jul 10, 2017 at 1:10
  • 1
    $\begingroup$ All that noise is a distraction, it is output that you will see every time you run blender, it is from addon changes that still have settings saved in your startup file. If you expand the info editor you should see the name of the operator called by the shortcut, which may help. $\endgroup$
    – sambler
    Jul 10, 2017 at 2:02

1 Answer 1

1
$\begingroup$

Here's a fix, I had same problem for a while where shortest path edge select marked them as freestyle

Apparently I have changed some options on Edge Select mode and forgot. Hope this fixes it

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.