2
$\begingroup$

I'm currently modelling a floodlight, but I'm stuck. The following image shows the front covering. In the middle, you see that the Subsurf modifier is smothing the three edges, but I want them to be sharp, so that the faces around it shape a frame.

overview

What modifiers I've used: modifiers

What I've already tried:

  • I've selected the edges and marked them sharp (Ctrl + E --> Mark Sharp) and used this with the EdgeSplit modifier

  • I've tried the Auto Smooth option (Object Data --> Normals --> Auto Smooth)

  • I've tried using loop cuts but they don't work properly in my case

  • I've tried using Edge Crease (Shift + E)

  • I've tried changing the order of the modifiers

All these options didn't work for me, so I'm thankfull for all help ;)

$\endgroup$
  • $\begingroup$ Did you try placing subdivision at the top and setting it to simple? $\endgroup$ – Aoradon Jul 7 '17 at 18:18
  • $\begingroup$ Now I've tried it out and it worked for the edges I've talked about. But your method caused another problem: I can't adjust the bevel width for the other edges anymore when the width reaches a small number like 0.05. So the rounding is very small. $\endgroup$ – New3D Jul 7 '17 at 19:02
  • $\begingroup$ If using Subsurf you either need edge crease or supporting loopcuts. In your case, you can turn the angle limit of Bevel modifier to something like 25 degrees and it will create sharper edges required for corners. Another option is to crease both angled edges in the corners and opened edge loop and delete Bevel from the modifier stack (it will make things more complex if you need it). See blender.stackexchange.com/questions/6425/… $\endgroup$ – Mr Zak Jul 7 '17 at 20:12
2
$\begingroup$

It appears you already tried a Crease factor on those edges using shift-e

https://docs.blender.org/manual/en/dev/modeling/meshes/editing/edges.html

This edge property, a value between (0.0 to 1.0), is used by the Subdivision Surface Modifier to control the sharpness of the edges in the subdivided mesh. This operator enters an interactive mode (a bit like transform tools), where by moving the mouse (or typing a value with the keyboard) you can set the (average) crease value of selected edges. A negative value will subtract from the actual crease value, if present. To clear the crease edge property, enter a value of -1.

It turns out creasing just the edges of the opening is not enough. You also have to crease the diagonal edges that have a vertex on the opening:

crease moar!

$\endgroup$
  • $\begingroup$ I applied the bevel modifier and set the crease for the three edges to -1 but it didn't work. In this state, I tried again using EdgeSplit and marked the edges sharp but no changes. $\endgroup$ – New3D Jul 7 '17 at 18:40
  • $\begingroup$ You want to set the crease to +1.0, not -1.0. I have updated my answer to state this explicitly. $\endgroup$ – Mutant Bob Jul 7 '17 at 18:53
  • $\begingroup$ This doesn't work either. In general, I don't get why the "Mark Sharp" tool doesn't work on this mesh. $\endgroup$ – New3D Jul 7 '17 at 19:17
  • $\begingroup$ "sharp" is for the edge split operator (as stated in the manual page I referenced) and not for subdivision operators. $\endgroup$ – Mutant Bob Jul 7 '17 at 19:30
  • $\begingroup$ ugh, you're right. it turns out you need more creases than just the perimeter of the opening. $\endgroup$ – Mutant Bob Jul 7 '17 at 19:38
1
$\begingroup$

If you don't mind adding more geometry you can do this:

  1. Extrude the edges E and right click to leave the extruded edges in the same place
  2. Select more ctrl++ to select all the edges created and the originals
  3. Mark them sharp and set the Edge Mean Crease shift+E to 1
  4. Enable Auto Smooth

no subsurf on edges

$\endgroup$
  • $\begingroup$ Sorry, but for me this doesn't work. Maybe it has to do with your geometry: in the corner you have a square but I only have this one diagonal (see the first picture) How did you get this square? $\endgroup$ – New3D Jul 7 '17 at 18:58
  • $\begingroup$ Sorry, I just notice that difference. I had the squares by adding edge loops when I created the hole. You can try adding them using the knife tool, but even so, the bevel modifier only seems to work with bevel weights or vertex groups. I can't figure out a method with the geometry you have. $\endgroup$ – Matt Ferndz Jul 7 '17 at 20:18
0
$\begingroup$

Here’s another option without using Edge Split:

I Mirrored on the “X” and “Z” axis but you don't have too.

Add a Loop Cut to the top. Press CTRL + “R” > Left Click > Right Click (To set in place). enter image description here

Select the bottom vertex then press SHIFT + “V” to slide it close to the corner. enter image description here

Repeat for the side. enter image description here

$\endgroup$
  • $\begingroup$ But this causes really nasty "wrinkles" even if you slide the vertices not close but onto the corner. $\endgroup$ – New3D Jul 7 '17 at 19:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.