7
$\begingroup$

What did I do? I somehow changed my view setting and I can no longer select anything with RMB. Please see screenshot: enter image description here

$\endgroup$
6
$\begingroup$

You have ticked an option that displays only objects that will be rendered. Open the Properties panel with N and untick Only Render under Display. You can actually select objects (the 3d manipulator widget is still being shown) and move them as normal, you just cannot see the visible outline.

enter image description here

$\endgroup$
6
  • $\begingroup$ Did I hit a key command for that? Don't want to repeat. $\endgroup$
    – kjfagan
    Apr 3 '14 at 16:32
  • $\begingroup$ @kjfagan No, there is no shortcut, you were probably poking around. $\endgroup$
    – iKlsR
    Apr 3 '14 at 16:33
  • $\begingroup$ HUGE. Thank you so much. Yeah, probably hit it on accident. $\endgroup$
    – kjfagan
    Apr 3 '14 at 16:33
  • $\begingroup$ @kjfagan feel free to accept the answer if it solve your problem. This will help future users. $\endgroup$
    – Vader
    Apr 3 '14 at 16:41
  • 1
    $\begingroup$ @iKlsR, actually I think there is a shorcut (can't remember if I bind it myself, or if it's default): ALT + SHIFT + Z $\endgroup$
    – Polosson
    Apr 3 '14 at 17:10
2
$\begingroup$

The original question was asked in 2014, 7 years ago. Now we are on blender 2.91. The down arrow next to Overlays icon in upper right corner of 3d viewport down arrow next to Overlays icon in upper right corner of 3d viewport produces this window Overlays dropdown. If grid is checked and floor is unchecked, what you see depends on the frontal vs top views and the orthographic vs perspective views.
Front ortho view grid
Front perpective no grid
Top perspctive no grid
Top ortho grid
If grid is unchecked and floor is unchecked
Front ortho no grid
Front perspective no grid
Top persective no grid
Top ortho no grid
If grid is unchecked and floor is checked
Front ortho no grid
Front perspective no grid
Top perspective grid
Top ortho no grid
If grid is checked and floor is checked
Front ortho grid
Front perspective no grid
Top perspective grid
Top ortho no grid
I hope that is clear and I hope it helps future blender users

$\endgroup$
1
$\begingroup$

Came here because my grid floor plane had disappeared as well. Realized it was because the 3D viewport shading was set to "Render". Changing it back to Solid fixed it. Shift+Z

$\endgroup$
1
$\begingroup$

In my instance, on Blender 2.80, I had to select "Grid" within the viewport overlays dropdown

Viewport overlays

$\endgroup$
1
  • $\begingroup$ And "Viewport Overlays" can be found from 3rd dropdown menu in top right corner of the viewport (icon looks like outline of circle overlapped with filled circle). As far as I can see, it cannot be accessed via normal menus nor context menus anywhere. $\endgroup$ Sep 28 '20 at 7:46
0
$\begingroup$

I had the same issue just now. Make sure your clipping distance is set up to 0.001m-10000m.

I know this is a little late, but hopefully it'll help anyone else looking around.

$\endgroup$
1
  • 1
    $\begingroup$ Clipping distance of 0.001m-10000m will probably cause viewport rendering artifacts / z-fighting (if changed in viewport) due to too high range of values set for showing the geometry with that precision which isn't necessarily supported by some GPUs. Also viewport grid usually doesn't require too precise clipping values since it's just optional displaying tool for convenience $\endgroup$
    – Mr Zak
    Dec 12 '20 at 16:00
0
$\begingroup$

In my case I was viewing the 'Layout' view instead of the 'Modeling'

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.