3
$\begingroup$

I'm trying to follow this tutorial: Create a Realistic City - Blender Tutorial

At timestamp 6:38, he selected all of the objects (using A) then joined them together using Ctrl+J. However, when I use Ctrl+J, nothing seems to happen.

I am using Blender v2.78

$\endgroup$
5
  • 1
    $\begingroup$ make sure you have no, non mesh objects selected, you can't merge lamps or cameras, I'd suggest deleting anything that's not a mesh. $\endgroup$
    – Firewill
    Commented Jul 6, 2017 at 20:36
  • 1
    $\begingroup$ Also, you need an active object for join to work. The active object is the last object you selected and has a brighter outline than the other selected objects. If you just deleted an object its possible there was no active object when you did Ctrl+J. $\endgroup$ Commented Jul 6, 2017 at 20:36
  • 1
    $\begingroup$ You need an active object to enable joining - indicated by the object being slightly lighter than the other objects. Shift select one of the object and try again. $\endgroup$
    – Patdog
    Commented Jul 6, 2017 at 20:37
  • 1
    $\begingroup$ @ Firewill - it doesn't matter if you have other objects selected - even cameras and lamps - as Blender will just ignore them. As long as some of the objects are meshes and one mesh is active, joining will work for the mesh objects. $\endgroup$
    – Patdog
    Commented Jul 6, 2017 at 21:01
  • $\begingroup$ i noticed there is a bug in blender that sometimes CTRL+J will not join the objects. i have verified this. $\endgroup$
    – Harry McKenzie
    Commented May 17, 2022 at 9:15

5 Answers 5

3
$\begingroup$

When your mouse cursor is hovering the 3D Viewport, it'll work.
But in other layers or areas, CTRL+J won't work.

$\endgroup$
1
$\begingroup$

This can be a solution in GUI:

Step one: make sure the ojects that you want to join are of the same type, i.e. all are meshes.

Step two: select the first object.

Step three: select the second object.

Step four: click 'Join' button shown in the screenshot here (yellow arrow) enter image description here

$\endgroup$
1
$\begingroup$

You may have a different keybinding set for this shortcut. To make sure you're using the right one, navigate to the following:

File > User Preferences

enter image description here

Input > Enter join in the search bar > Under Object Mode, read the keybind.

As you can see here, my keybind for join is set to J

If you want to change it back to default, click Restore. Make sure to hit Save User Settings before exiting.

enter image description here

If you're changing the keybind to a completely different setting, make sure no other functions have that same keybind.

$\endgroup$
1
$\begingroup$

This solution worked for me:

  • Select the 1st mesh in a collection.
  • Then SHIFT select the last mesh in the collection.
  • Then finally do CTRL+J while still selecting them.

screenshot

$\endgroup$
-3
$\begingroup$

Use Ctrl + J just at the beginning. When you import the city, press A then press Ctrl + J. It worked for me, hope it works for you, too.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .