0
$\begingroup$

Gap Between Domain And Actual Collision Of Fluid

Just to start off and explain things, I've been having this problem whenever I try and create a fluid domain so I created the simplest example possible. The bounding box seen is not the domain but an exact copy to show the boundaries. I used to have great fluid simulations, now this happens and for some reason any objects set to obstacle are ignored by the fluid, any help would be appreciated Also, if you're having trouble seeing the problem, download the blend file and if it's not my computer causing it locally, you should see that the fluid doesn't collide with the domain properly, there's gaps between all the sides.

$\endgroup$
  • 1
    $\begingroup$ Can you add the .blend file so we can take a look? Just the screenshot isn't much to go off $\endgroup$ – Freddie R Jul 6 '17 at 11:55
  • 2
    $\begingroup$ sorry, "this happens" means? $\endgroup$ – m.ardito Jul 6 '17 at 12:45
  • 2
    $\begingroup$ @FreddieR If you are going to suggest adding a blend file (which should ideally be done as a last resort, after clearly explaining the problem) you should mention the upload service they should use: blend-exchange.giantcowfilms.com $\endgroup$ – Ray Mairlot Jul 6 '17 at 14:28
  • $\begingroup$ @FreddieR All done and added $\endgroup$ – kyle lozinski Jul 8 '17 at 5:48
  • $\begingroup$ @m.ardito there's a gap between the fluid and the domain, the collisions aren't working properly $\endgroup$ – kyle lozinski Jul 8 '17 at 5:49
2
$\begingroup$

Increase the resolution to reduce the gap.

The "glitch" you are experiencing is indeed an artifact of the low-resolution simulation.

The fluid simulation is computed on a grid of N × N × N small cubes, N being your "Final" resolution setting. Every detail of the 3D world, like the boundary location or an obstacle, that is smaller than the diameter of these cubes may be ignored by the simulation. Therefore, you should always expect gaps that are as large as one N-th of the edge of the simulation box.

In your example, you are simulating at N = 65 and visualizing the "Preview" mode at N = 45. Since your gap is around 1/45-th of the box size, it shouldn't be considered a glitch.

Increase your "Final" simulation resolution to ~150 and switch the "Viewport display" to "Final" to see the difference it makes.


Your file simualted at Final = 300 and Viewport display = Final

enter image description here

$\endgroup$
0
$\begingroup$

I, like you, also remember perfect domain to simulation walls parity, but I think I just never noticed the small gap before.

I checked Blender 2.78, 2.79, 2.8, and 2.5, all exhibit the same behaviour.

So I'd say this is as it has always been.

$\endgroup$
  • $\begingroup$ I had it working perfectly and then in the same version this started happening (I was on like 2.3 or something) and then I updated and it stayed consistent, hopefully we can find an answer to if this changed in an update, I've also been having problems with fluids ignoring things designated as obstacles, any troubleshooting I can do that would work or should I be more specific? $\endgroup$ – kyle lozinski Jul 9 '17 at 3:53
  • $\begingroup$ best thing right now would be to ge 5+ people to notify if theyre getting the same bahaviour, I don't think anything external can break this, if I understand correctly this depends solely on cpu. I tried looking at a few other videos online and while it is difficult to tell I'd say that the gap is there. kinda offtopic but why do you care about the gap? it's not something that I can see being a huge problem. $\endgroup$ – Firewill Jul 9 '17 at 4:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.