1
$\begingroup$

I have a problem with a normal map.

There are 2 models: low-poly and high-poly. I've baked a normalmap from highpoly to lowpoly model, and this normal map looks perfect. But when I use it (a Normal Map node of Cycles render), I have these seams. enter image description here

The smooth shading is enabled both in low-poly and high-poly model. As I've said before, the normal map looks good, there are no any seams on it.

Some guys say, that it's impossible to fix it on Cycles render. So, what do you think? Can I solve this problem?

P.S. Triangulation didn't help. Subsurf can make the problem less noticeable, but not fix it fully.

$\endgroup$
5
  • 1
    $\begingroup$ Where is the seam of the UV map used for baking? Could it be that UV islands were intersecting a bit? Try inreasing the Margin setting to make some borders around the islands. Make sure that the UV map used for baking is used for rendering $\endgroup$
    – Mr Zak
    Jul 5, 2017 at 18:31
  • 1
    $\begingroup$ How does it looks without the normal map? You mention that adding a subsurf makes the problem less noticeable, which makes me think that is not related to the normal map, but to the way Cycles handles the smooth shading, see here: blender.stackexchange.com/questions/1998/… $\endgroup$ Jul 5, 2017 at 19:17
  • $\begingroup$ I've removed a normal map, but the problem is stil here. So, is adding geometry the only way? $\endgroup$
    – Mapper720
    Jul 6, 2017 at 18:19
  • $\begingroup$ There are so many potential problems that it will take a very long time to diagnose unless you upload your .blend, including your highpoly model, and your texture. $\endgroup$ Aug 5, 2017 at 14:26
  • $\begingroup$ I cant't upload this .blend now. I just have no that file already :) About the problem - I think this is not normal map issue and it can't be fixed in Blender (correct me, if I am wrong). $\endgroup$
    – Mapper720
    Aug 6, 2017 at 18:50

2 Answers 2

2
$\begingroup$

Commenting in case anyone runs into this post in search results because I'm way too late for the original post.

I ran into this exact problem and setting the image texture's color space to "Non-Color" fixed it for me.

$\endgroup$
2
  • $\begingroup$ Look at the screenshot, it's non-color $\endgroup$ Jun 10, 2020 at 7:53
  • $\begingroup$ This is possible. There's also the possibility that it's just a lighting issue. Place a point light under the arm and see if it goes away. $\endgroup$ Jun 10, 2020 at 7:53
1
$\begingroup$

Your UV islands are too close together. Give each UV island enough space for the baking process to expand the colors beyond UV islands bounds.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .