4
$\begingroup$

I have an object falling to the ground and breaking into pieces, but my plane, which is a passive rigid body, allows many pieces to pass through it:

Before

In The Animation

Why is this happening and how can I fix it?

$\endgroup$
5
$\begingroup$

You can add a collision margin on the plane (the passive rigid body).

Also, increasing the number of simulation steps per frame from the rigid body properties panel in Scene properties tab will give you better results.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Increasing the number of steps did the trick (for a box), thanks! $\endgroup$ – Romuald Brunet Aug 11 '19 at 12:18
3
$\begingroup$

Planes are notoriously bad objects to use as solid collision objects. I would suggest to use a cube, with a cube bounding box.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Agreed. Pop a very subtle solidify on there and see if you get better results. $\endgroup$ – Andrew Jul 4 '17 at 9:47
  • $\begingroup$ How to make a Cube with A Cube bounding box ? $\endgroup$ – Shams El-Deen Jul 4 '17 at 10:00
  • $\begingroup$ Switch "Shape" from Rigid Body Options from Mesh to Box $\endgroup$ – AdamTM Jul 4 '17 at 10:26
0
$\begingroup$

In the Rigid settings pannel, if you are using a plane or a cube, change the default Convex Hull in Collisions shape to box, so it simulates the collision of a cube

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.