1
$\begingroup$

I have a linked object in a master file. I then create a proxy of the rig, and everything works as expected, I then save and close the file.

enter image description here

But when returning to the master file, the mesh is completely deformed.

enter image description here

If I put the armature in 'Rest Position' or remove the armature modifier and re-rig the object from scratch, I no longer get the problem.

The object in the linked file has scale and rotation applied, and the armature seems fine as well (using rigify). I'm new to working on a large scale project and using linked objects, so is it possible a step could have been missed, or if this could be a bug? (Using Blender 2.78c)

$\endgroup$
3
  • $\begingroup$ do you see a button next to the render enigne selector that says "reload trusted"? $\endgroup$ – Firewill Jul 2 '17 at 23:09
  • $\begingroup$ No, there isn't that option $\endgroup$ – milesholt Jul 2 '17 at 23:56
  • $\begingroup$ I am new to blender so i dont know how much or if at all this will help. I have the same type of problem with my mesh being disfigured after opening the saved file. Below attached link helped me save that rig without getting the mesh disproportionate. LINK: youtube.com/watch?v=o6_AzySr64c&t=400s Hope it helps Cheers $\endgroup$ – Aadeesh Shrivastava Jun 30 at 16:13
1
$\begingroup$

As Firewill noted, it is a standard problem with python scripts. By default, Blender disables running scripts from scene, because downloaded scripts may contents malware.

So, to run this scripts you mast press "Reload trusted" in header of window, to confirm that blender may trust scripts:

enter image description here

If for some reason, you haven't this buttons, there is a workaround: Open User Preferences, in File tab click auto run python scripts:

enter image description here

In this case it is recommended to add a downloads path as Excluded.

$\endgroup$
1
  • $\begingroup$ I see what you and Firewill have pointed out, but unfortunately, this is already enabled. $\endgroup$ – milesholt Jul 3 '17 at 18:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.