So I'm trying to make some very refractive glass in Blender Cycles. I've tried using the mix shader with Glass, Trasparency, by a factor of Is Shadow Ray + Is Reflection/Trasparency Ray etc, and I've also messed with every setting in the Light Paths section of the Render Properties.. but nothing will get rid of these black corners (see picture below), even though there is nothing black or unlit in my scene. enter image description here

In the past I've used Cinema 4D, and I would just turn off every channel in a new material except for Trasparency, and then just mess with the Refraction value, and I would get a very clean, realistic-looking glass material (see picture below). You can still see a few black spots I think, but, it just looks so much more refractive and clean. What I'm wondering, is what Cinema 4D does by default in this scenario, that Blender doesn't, and what settings I need to adjust in Blender to get the same result as Cinema 4D's default Transparency/Refraction settings. Any help would be so much appreciated!! Thank you!! (I've searched through YouTube, and Google Search, and this website a ton looking for every related keyword I could think of, but haven't found the answer to this issue yet :o the closest thing I found was this What's the difference between refraction and glass shader? and at the end of the answer the guy even says he doesn't know what causes the black bits)

enter image description here

  • $\begingroup$ can you provide a test file? it looks like either a lightpass issue, but you have cranked those to max or some interior faces/normal issue. $\endgroup$ – Firewill Jul 2 '17 at 21:53
  • $\begingroup$ Is there a way to upload the file directly here? $\endgroup$ – M. O. Marmalade Jul 2 '17 at 21:56
  • $\begingroup$ It's like 250mb because I don't know how to turn high poly into a normal map yet, and my dropbox is full :o $\endgroup$ – M. O. Marmalade Jul 2 '17 at 21:57
  • $\begingroup$ there is, blend-exchange.giantcowfilms.com tough if you could reduce the polycount using the decimate modifier or something I'd appreciate it, my internet is pretty slow :L $\endgroup$ – Firewill Jul 2 '17 at 21:58
  • $\begingroup$ dropbox.com/s/9xe8d2z4tspmtl8/BOOMee.blend?dl=0 I ended up deleting everything from my dropbox, plus the max upload size on stackexchange seems to be 30mb anyways :o $\endgroup$ – M. O. Marmalade Jul 2 '17 at 22:00

I see you have Transmission bounces set really high, but I think one of the causes might be a lack of Glossy bounces which is actually what handles all the reflections on the Glass shader. Without it, Glass would just refract and be transparent.

enter image description here

  • $\begingroup$ GASP you're an angel!!!! I tried increasing the glossy bounces and it immediately fixed it! :D so, what was happening? the internal faces were bouncing back and forth more times than the glossy bounces could handle? $\endgroup$ – M. O. Marmalade Jul 2 '17 at 22:29
  • 1
    $\begingroup$ Ah :o ok! I need to look into how nodes work more.. I know they each handle specific tasks, but I don't know how specialized they are I guess (whether glass is just transparent, or if it includes reflection as well) Thank you so much for your help bertmoog!! :D $\endgroup$ – M. O. Marmalade Jul 2 '17 at 22:41

For me increasing the amount of the bounces didn't help so i fixed it by enabling the auto smooth.

Here's how

  1. Select your glass object
  2. On the properties panel in the right hand side, Go to Object Data Properties tab
  3. Click on Normal dropdown.
  4. Enable Auto Smooth

I hope this helps someone.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.