14
$\begingroup$

Sometimes when adding an object to the scene I see that all options (on toolbar or in window after pressing F6) are disabled. Can anyone tell me when can this happen? What is causing it and how to revert it - make it enabled again. It worked for me when I restarted Blender and reloaded the scene. However I would really like to know what can cause it?

$\endgroup$
17
$\begingroup$

It sounds like you may have disabled Global Undo in CtrlAltU> User preferences > Editing:

enter image description here


That panel is called the redo panel, because when you change a setting on it, blender actually redoes the previous operator with the new settings.
If blender can't undo the previous operator first, running it again will add it's effect on top of the result of the previous operator (which is not the desired effect at all).

So this panel is disabled when undo is not available.

$\endgroup$
  • 1
    $\begingroup$ Actually I have the Global undo checked. $\endgroup$ – komi3D Apr 3 '14 at 10:56
  • 2
    $\begingroup$ I checked the Global Undo checkbox, but still had the same problem described by the question. It wasn't until I restarted Blender that this solved the problem. $\endgroup$ – MechtEngineer Apr 20 '17 at 3:57
6
$\begingroup$

It turned out that it happened to me when using the Curve Dimension addon.

When I added one dimension and changed its type from 2D to 3D, it crashed the addon (I need to report this to the author). However, this crash caused (that when adding any other objects including the curve dimension) all options F6 to be disabled. My solution to this was to restart Blender and reload the file. So I guess, that it is possible that some other addons which create geometry may cause the options to become disabled too.

$\endgroup$
  • 1
    $\begingroup$ Any add-on that enables and disables the undo system should take extra care that the undo is re-enabled if it encounters an exception -- it won't be limited to geometry add-ons. $\endgroup$ – zeffii Sep 22 '15 at 8:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.