0
$\begingroup$

I am trying to simulate the fluid in a pipe. The fluid obstacle object (pipe) is converted to mesh from a path. I have set a fluid inflow at one end of the pipe and fluid outflow at one end of the pipe. When I try to bake the fluid domain it stays as a cube and nothing happens.

Just as a test, I created a simple pipe (converted to mesh from a path) in another file and tried to flow the fluid through the pipe, it was quite slow and sluggish as compared to the simple pipe extruded from a cube.

Is the failure in the fluid simulation is due to more complexity of the obstacle object or some problem with setting of fluid objects? the shape of fluid obstacle object

$\endgroup$
  • $\begingroup$ I doubt the simulator wil get the result you want. Increase the resolution to get more detail that will fit in the tube, try 512. Set the obstacle to use free slip. Resize the domain so there is less extra space to help speed it up. Adjust the real world size and time, the defaults give you a domain that is 0.5 meters long and the sim is 4 seconds long which is spread over your 600 frames. Look over the setting info. $\endgroup$ – sambler Jul 1 '17 at 10:24
  • $\begingroup$ I scaled down the domain, the obstacle, the inflow object and the outflow object, and set the real world size to 10, end time to 20 and resolution to 512. Still it is not able to simulate the fluid with the obstacle. Thanks for your suggestion. $\endgroup$ – hemant kumar Jul 1 '17 at 15:14
  • $\begingroup$ Scaling down the obstacle will make the size of the needed water smaller making it harder to fill. By also increasing the wall thickness I get to the a at about 10% but the corners are still leaking. This is the blend if you can find something else I changed. $\endgroup$ – sambler Jul 2 '17 at 5:58
0
$\begingroup$

Aside from making the resolution high, you would need to subdivide the fluid, and increase the fluid speed and duration to match your animation. I.e. if you are running a 500 frame animation at 50fps, set the fluid time: (1 to 500/50). This will match the fluid speed to your animation so that it doesn't go slower than normal. Lastly, if you don't have the computer memory to run the sim at a high resolution, scale up the objects while keeping the domain at the smallest you can. It needs to be bigger than the fluid objects, though.

| improve this answer | |
$\endgroup$
0
$\begingroup$

I had the same problem and the solution was that in order for the domain to work, the inflow and the path have to be inside the domain box.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.