I found an answer for Blender Internal engine at I want to make a projector show an image displayed on surfaces

But I want to accomplish something similar in Cycles. I tried attaching a texture node to the lamp's node tree, but it seems the color pattern is based on the world coordinates and does not rotate with the spot lamp.

node setup for textured spot lamp

What is the correct node setup for a cycles lamp so that its texture rotates and moves with the lamp?

  • $\begingroup$ I'm beginning to think that my real problem was that my 2.78a version of blender was haunted, because switching to 2.78c solved the problem. $\endgroup$
    – Mutant Bob
    Commented Jun 29, 2017 at 21:42

1 Answer 1


You can do this with a spotlight using the pretty much the same node setup as you have but with an additional mapping node to position the image.

enter image description here

You also need to be sure to set the spotlight light size to something small or your projected image will look blurry.

enter image description here

And the result.

enter image description here


Here's it working with your blend file, no settings changed:

enter image description here enter image description here

  • $\begingroup$ You might have to go into a little more detail. I added that mapping node, but when I rotate my lamp, the texture does not move with the spot light, so it is no improvement over my original node setup. $\endgroup$
    – Mutant Bob
    Commented Jun 29, 2017 at 18:31
  • $\begingroup$ I can't seem to reproduce the problem... The mapping node just fixes to orientation of the image. The image rotates with the spotlight for me. Could you upload a .blend? $\endgroup$ Commented Jun 29, 2017 at 18:40
  • $\begingroup$ pasteall.org/blend/index.php?id=47047 in case you want to see an example of a .blend with my problem. If I alter the rotation of the lamp, the texture doesn't move with the spot. $\endgroup$
    – Mutant Bob
    Commented Jun 29, 2017 at 18:46
  • $\begingroup$ What version of Blender are you using? The texture rotates fine for me with your blend file. $\endgroup$ Commented Jun 29, 2017 at 18:48
  • 1
    $\begingroup$ There must be something different between our environments because your blend file, on my machine with 2.78a is doing exactly what you want it to do. $\endgroup$ Commented Jun 29, 2017 at 18:55

Not the answer you're looking for? Browse other questions tagged .