0
$\begingroup$

I am a fresh Blender user. I started collecting training videos and some of them are very explanatory indeed. So I guessed, following their instructions I could manage. The problem I describe here is a problem I have with all the videos I shot with my Panasonic Camcorder HC-VX870.

In this video, wanted to blur the ship floating on the river Seine.

System imformation : Computer ASUS Desktop PC P30AD Processor 4 Intel Core i3-4160 CPU @ 3,60 Ghz Memory : 3914 MB OS : Ubuntu 16.04.2 LTS

Specs of the video : Duration : 1 minute 24 seconds Container : Quicktime

Video : Dimensions : 3840 x 2160 Codec : H.264 (High profile) Frame rate : 25 fps Bit rate : 61128 kbps

Audio : Codec : MPEG4-AAC Channels : Stereo Sample rate : 48000 Hz Bit rate : 256 kbps

Media details Demuxer : lavfpref

Let us now take a look at the process itself.

Step 1 : I add the video. It appears in the upper-right side window. Everything works fine.

Step 2 : I open the UV Image Editor in the upper-left side window . OK.

Step 3 : I create my mask (upper-ledt side window). I call it Blur_01. OK.

Step 4 : In the Upper-left side window, I open the video. It appears. No sinc yet, but so far, so good.

Step 5 : In the Upper-left side window, I select View/Properties, in order to sync the left side and right side. ![file:///home/olivier/Pictures/05_SelectProperties.jpg

Step 6 : In the Upper-left side window, I now tick the Match movie length and Auto Refresh boxes… and the video disappears. ![file:///home/olivier/Pictures/06_MatchMovieLength.jpg

I have been trying hard over the past week to solve this problem, to little avail, so I am turning to you now.

I also tried on Blender 2,76. I managed to move my mask around in the UV Image Editor, then I ended up with two cases :

  • If I start from image 1 (say image 1 to image 50), everything seems t work fine and I manage to get full sync (i.e. the mask moves around nicely in both windows).

  • If I start from another image (say image 51 to 100), then I cannot get the sync and, while the mask moves around in the Upper-left side window, it stays stuck at image 51 in the Upper -right side window.

I hope I clearly stated the nature of my problem. Thanking you in advance for your time and efforts.

$\endgroup$
3
  • $\begingroup$ It could really help if you try with the last version 2.78c because it could be a bug. $\endgroup$
    – PhoneixS
    Commented Jun 28, 2017 at 7:02
  • $\begingroup$ Hi, thanks for your reply. Actually, the version I am using is already 2.78c. Indeed, I had not noticed the (little) c coming after '2.78' in the opening splash window. $\endgroup$ Commented Jun 29, 2017 at 7:53
  • $\begingroup$ I lately tried with version 2.79 and faced the same issue. Too bad, as Blender seems to be the software I need. Thanks for your time and effort anyway. I'll keep trying... $\endgroup$ Commented Jul 13, 2017 at 4:36

1 Answer 1

1
$\begingroup$

I recommend you to convert the video to an image secuence, you can do it with Blender if you want, render the video without changes to a series of images. Anyway I prefer using ffmpeg to do this job, is free and you have lots of examples on Internet.

I think the problem could be that, as the video is encoded, a frame in the middle could not exist (completely) and this is why it can't show the image.

$\endgroup$
7
  • $\begingroup$ I just converted part of one of my videos (image 392 to 480) to an image (PNG) sequence. I got all the 89 frames complete, so none of them is missing. I did the same with another of my videos and again got a continuous sequence of PNG images, with none missing. $\endgroup$ Commented Jul 14, 2017 at 3:45
  • $\begingroup$ I also tried to convert some my *.mp4 videos into *.avi videos. It worked nicely but when I tried to apply the process I initially described, I ended up with the same issue. $\endgroup$ Commented Jul 14, 2017 at 3:48
  • $\begingroup$ @olivermassot the issue appears when you use the avi or the png sequence? $\endgroup$
    – PhoneixS
    Commented Jul 14, 2017 at 5:57
  • $\begingroup$ The issue appears when I use the avi format. Actually, sometimes the video simply does not appear on the Upper-left side window, or it freezes on one frame (as soon as I tick on the Match movie length box. $\endgroup$ Commented Jul 14, 2017 at 6:49
  • $\begingroup$ The problem with the avi is the same as you have before, encoded videos usually doesn't have all the frames as complete images and I always recommended to work directly with the image sequence strips. $\endgroup$
    – PhoneixS
    Commented Jul 14, 2017 at 7:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .