I recently purchased a new GPU, and AMD RX550 (4GB), but in Blender OpenCL does not appear as a choice. Would this have to do with the fact that AMDGPU-PRO drivers include AMD's OpenCL? I don't think xserv is running with the public OpenCL - How do I test that?

enter image description here


Processor: AMD FX on a Gigabyte 970A MB with 16 GB of Ram (GPU not integrated)

GPU: AMD XFX Radeon RX550 (Polaris 12)

OS: Ubuntu 16.04

Blender: 2.78c

Initially I installed version 2.76b (2.76.b+dfsg0-3build1) from the Ubuntu Software Center. I would see similar to the above screenshot only I would also see "CPU" as a choice.

The bummer is that I haven't seen or been able to utilize my GPU for rendering.

After reading a bunch of threads on this problem, I thought maybe it was my setup not working in that version (some had success with installing a direct package from the Blender.org website).

So, I downloaded and unpacked 2.78c from the website. When I ran blender it looks like the above screenshot. When it renders, it renders using the CPU (obviously as default), because I can see with my System Monitor the CPUs being pegged.

I'm still bummed though, because I can't use my GPU to render. Any ideas on how to get my system and blender to communicate? (that's my hypothesis...)

I (re-)downloaded and installed the latest drivers from AMD: AMDGPU-PRO Everything appears to have installed correctly - AMDGPU-PRO, OpenCL, etc...

However after install, I still have no choices

Also, lspci | grep VGA returns Advanced Micro Devices, Inc. [AMD/ATI] Device 699f (rev c7) - the name is a bit different, but it should be available, yes??

Any ideas on next steps?

Thanks for any help! --Dave

  • $\begingroup$ I don't use Linux or AMD cards, but it sounds like an OS issue to me. Just for kicks, you could try the 2.79 beta. It's suppose to have improved OpenCL support, but I doubt that's what's preventing Blender from recognizing the card. wiki.blender.org/index.php/Dev:Ref/Release_Notes/2.79 $\endgroup$
    – bertmoog
    Commented Jun 28, 2017 at 0:57
  • $\begingroup$ Also, FWIW, I have used an FX-8320 CPU with a Radeon HD 6870 (yes, the ancient generation) and I was able to GPU render on Windows 7 on Blender 2.77. $\endgroup$
    – bertmoog
    Commented Jun 28, 2017 at 1:01
  • $\begingroup$ @bertmoog thanks for your ideas. I really think it has to do with the way that blender is reading my system configuration. I've loaded blender on my work computer (W7) and I've been able to choose the correct GPU no problem. It's Linux & Blender conflicts. $\endgroup$
    – David
    Commented Jun 29, 2017 at 17:14

2 Answers 2


I know this isn't the answer you're looking for (it's not one I'm happy with either), but, at the moment—even two months after you first asked

You either need a different video card or a different OS.

OpenCL support is currently broken in the official AMD drivers for the RX 550 specifically {1}. This is still true as of the 17.30-465504 AMDGPU-PRO drivers and Ubuntu 16.04.3 (which they finally support).

While the card supports OpenCL natively and works in Windows, it is unclear when fully working (i.e. including OpenCL) Linux drivers will be released.

A comment on the AMD Community boards suggests that there is a working internal build that has been tested against the RX 550 as of August 11th, 2017. When this will be publicly released is unclear as of now. In addition to the evidence I've linked to supporting this conclusion, I've personally confirmed that the issue is specific to the RX 550 by dropping an RX 580 into a Ubuntu 16.04.3 system with identical drivers without any issue: the RX 580 shows up and works fine with OpenCL, the RX 550 continues to not be seen as an OpenCL device.

I've also personally tried the oibaf open source drivers, but have not been able to get OpenCL working on the RX 550 with them. This weekend I will give that another try using Ubuntu Zesty instead of the 16.04 LTS, now that I have an RX 580 to help act as a control comparison case.

I would suggest posting in the above linked thread or contacting AMD directly, referencing the linked comment, and asking for the internal build that is working for OpenCL on the RX 550. Otherwise the only available options seem to be either waiting for them to be released publicly, getting a different graphics card, or not using Linux with the RX 550 for now.

{1}: Supporting evidence (in addition to the thread linked in the second paragraph):

  • $\begingroup$ Allegedly the fix: cgit.freedesktop.org/mesa/mesa/commit/… $\endgroup$ Commented Sep 20, 2017 at 22:21
  • $\begingroup$ It's 3 years later and google bought me here, My RX 550 does not have the OpenCL option, I have amdgpu-pro-20.30-110958 installed and the current Blender, so has it still not been fixed? $\endgroup$ Commented Aug 26, 2020 at 10:09

Today I found a solution in installing drivers for this video card here https://forum.ubuntu-it.org/viewtopic.php?t=639965

I ran the installation with options (previously - removed the driver):

sudo ./amdgpu-pro-install -y --opencl=pal,legacy --headless
  • OS: Ubuntu 20.04
  • Blender: 2.83.10
  • Radeon™ Software for Linux® Driver for Ubuntu 20.04.1: 20.45 (Download driver)
  • GPU: AMD Radeon RX550
  • CPU: AMD FX-6100

enter image description here

I'll add that after a reboot, I was unable to start a user session ... I had to go through the following steps to restore the system:

  • upgrade the system kernel to 5.10.6-051006-generic
  • kernel module amdgpu set to autoload in file /etc/modules-load.d/modules.conf (just added the module name amdgpu)
  • also deleted amdgpu from the black list - moved the file to a temporary folder mv /etc/modprobe.d/blacklist-amdgpu.conf ~/downloads/
  • executed the command update-initramfs -u after that the work was restored.

install linux-image-5.4.0-54-generic only see here for more information

upd: New driver 21.10 with linux-image-5.8.18-050818-generic works now too


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .