I follow this tutorial which uses rigify and I have run into some issues.


Not every vertex moves along the rig. Any idea what could cause this? I applied the location and rotation for every object.

The entire head is weight painted with blue.

blend file

  • $\begingroup$ Maik, one thing that occurred to me is you might want to try going back to Blender version 2.69 and seeing if Rigify works properly in there for you. If not, or if you want to use Blender 2.70, you may want to consider not using Rigify and making your own armature instead. My tutorial on how to place bones in a figure might be of use when making your own armature: youtube.com/watch?v=rlELC7vfC-4 $\endgroup$ Commented Apr 2, 2014 at 14:50
  • $\begingroup$ Also, if you want to learn about vertex groups, try this tutorial: youtube.com/watch?v=Z6bfWJwi8_k $\endgroup$ Commented Apr 2, 2014 at 14:51
  • $\begingroup$ To learn about rigging, try this tutorial: Part 1: youtube.com/… and also Part 2: youtube.com/… $\endgroup$ Commented Apr 2, 2014 at 14:54
  • $\begingroup$ Here is a great tutorial about weight painting, vertex groups and also bone envelopes: youtube.com/watch?v=KrTG-fjh1TI $\endgroup$ Commented Apr 2, 2014 at 14:59

1 Answer 1


To solve this issue, you need to:

  1. Make sure the mesh weights are set correctly
  2. Probably join all the body part meshes into one mesh
  3. Make you rig bind to the mesh using bone envelopes or vertex groups. If you choose bone envelopes, make sure they encapsulate all parts of your mesh so they effect all parts of the mesh. If you choose vertex groups, make sure all the vertices of the mesh are accounted for in all the vertex groups.

That being said, you can follow the steps I've laid out here until you get to the end, and then try googling adjusting bone envelopes or vertex groups, or hopefully I or someone else can figure out how to get it working properly so I can finish giving step-by-step instructions.

Moving a Mesh with an Armature

In order to move a mesh with an armature/rig, you need to:

  1. Make sure the Weight for your mesh is set correctly
  2. Make sure your mesh is bound to the rig correctly with either Vertex Groups or Bone Envelopes

Weight Painting

Weights for mesh objects that you want to be moved by your rig/armature must be painted something other than blue:

  • Blue means it will be effected 0% by rig movement
  • Red mesh will be 100% effected you the rig
  • Any color in between blue and red will be partially effected by the rig movement:

enter image description here

  1. Since your figure's body is divided into different meshes, I suggest you join all body parts together into one mesh so the rig will effect them as one mesh. Perhaps it's possible to use the rig with all the parts separate like they are now, but I don't know how to do that. So, I recommend selecting all parts and then using the Join command by pressing CTRLJ.

    Now you need to paint all parts of your mesh with the correct weights:

  2. Select the figure

  3. Select Weight Paint mode in the 3D Viewport header:

    enter image description here

  4. Now adjust the brush settings and paint. NOTE: If you want an easy way to paint every part of your mesh red so it'll all move 100% with the rig, then make sure Limit Selection to Visible is disabled so that when you paint, it'll paint even parts of the mesh you can't see (i.e. the back sides, etc), as shown in the video below:

    enter image description here

    enter image description here

  5. You might want to paint the hair and the leaf dress to something other than full red in case you want them to move slightly differently. You can read more about weight paint here on the Blender wiki.

  6. Now that you've taken care of the mesh weights, let's move on to the rig and how it's attached to the mesh. You might consider turning off the visibility of the controls you are not using at the moment so it's easier to grab the ones you want. To do this, open the Properties panel (N), scroll down to the bottom and toggle off the visibility of the ones you're not using, like this:

    enter image description here

    This will leave only the IK (Inverse Kinematics) controls visible so they'll be MUCH easier to find & select when you're posing the rig.

    NOTE: If you're not sure about whether to use FK or IK controls, see the answer here for a detailed description of what FK and IK controls do.

  7. Next, select your rig, then enable Auto IK in the Options tab:
    Tools panel (T) -> Options tab -> enable Auto IK

    enter image description here

  8. Now you need to bind the vertices of your mesh to your rig/armature using either Vertex Groups or Bone Envelopes:

Bind to Vertex Groups and/or Bone Envelopes

One common cause of parts of the mesh not moving with an armature can be related to how you bind the armature to your mesh -- whether you have Bind to Vertex Groups, Bone Envelopes, both or neither selected. If you'd like to read more about Vertex Groups and Bone Envelopes, you can read more about them here:

In this instance, I'll show how to bind using bone envelopes.

  1. First, make sure you only have 1 Armature modifier on your figure, then set it so only Bind to Bone Envelopes is selected:

    enter image description here

  2. Then, select the rig, go into Edit mode, and in the Properties panel (N) adjust the size of the radius and envelope of each bone to make sure it encompass all parts of the mesh it's intended to move:

    enter image description here

    Then, when you go into Pose mode to pose your figure, if part of the mesh doesn't move properly, like the parts of her face you showed in your picture, then that means the radius and/or envelope of the bone governing the head movement is not large enough.

More On Rigify

For more information about some of Rigify's not so obvious features, see this question.

  • $\begingroup$ Thanks for the detailed explanation but it didn't help. I think I messed something up. I am going to follow the tutorial again and I also uploaded the blend file. $\endgroup$
    – Maik Klein
    Commented Apr 1, 2014 at 19:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .