4
$\begingroup$

I am having trouble with a rig I imported from MakeHuman. When I run the Embedded Player or the Standalone Player my character's facial features come through the mesh.

They are positioned properly, but for some reason they seem to get priority over the outer mesh and are displayed through the outer skin.

Here is a picture to illustrate my conundrum:

enter image description here

$\endgroup$
  • 1
    $\begingroup$ Can you please upload your blend file so we can check to see what is causing this? $\endgroup$ – Thom Blair III Apr 1 '14 at 18:52
  • $\begingroup$ My blend file was too big to upload but here is a link to my Q with the code and some extra info: link Thanks for the help! $\endgroup$ – CubeBot88 Apr 2 '14 at 7:00
  • $\begingroup$ If you want to upload a file of almost unlimited size, you can use Google Drive (drive.google.com) -- they give you 15GB of storage and the links don't ever expire. $\endgroup$ – Thom Blair III Apr 2 '14 at 14:35
  • $\begingroup$ However I can't help you with anything related to code because I'm not a programmer. But, if you want more help here on StackExchange, you should revise your question to explicitly describe the code you used and also add coding-related tags to your question so that the coding experts might be more inclined to examine the question. There are lots of coders here that might be able to help. $\endgroup$ – Thom Blair III Apr 2 '14 at 14:38
  • $\begingroup$ One thought I have, though, is that it might be that you have the teeth and eyes on a layer that is rendered on top of the body, in which case you would need to make sure the render layer containing the teeth and eyes is below the layer containing the body. I don't know if that's you issue, but it's worth checking. $\endgroup$ – Thom Blair III Apr 2 '14 at 14:40
1
$\begingroup$

The simpliest way (and only one known to me) is to go to "user prefernces-editing" and in "Duplicate data" uncheck the "Metaball". Then duplicate problematic meshes. Duplicates shoudn't have these problems.

$\endgroup$
1
$\begingroup$

Game Mode: In Properties tab, go to the material section and open the game setting. Set the mode to alpha clip, alpha blend. The problem is the order AI decide to prioritizes the order.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.