3
$\begingroup$

In order to create clouds in the background of landscape I followed instructions of the lesson and used the Image node to add image needed in the result. Then I mixed that image with color (by using AlphaOver node) added by the RGB node to make environment look more realistic.
So, we have clouds created.
Then Mist socket from the RenderLayers is used to give infromation to ColorRamp node about the mist we want to get. ColorRamp's Image output socket is connected to Fac socket of the Mix node. Our clouds are added to the first Image socket, and the main Image from RenderLayers - to the next one.

I would like to ask about this way of mist creating. How is it possible to avoid of translucence of clouds through the island and at the same time leave mist? I tried a lot and didn't found any ways to combine these 2 images without getting problem when clouds can be seen through the front image (in this case, island).

Screenshot of the nodes set up. enter image description here

To point out your attention at the problem, screenshot of the rendered image if ColorRamp node settings are changed (mist managing). enter image description here
UPD.

I'd like to say that I think my island wasn't behind the clouds but rather the island lost transparency according to the principles mist settings are processed in Blender. You might want to look for references - http://wiki.blender.org/index.php/Doc:2.6/Manual/World/Mist#Transparency, this one - http://en.wikibooks.org/wiki/Blender_3D:_Noob_to_Pro/Mist_-_Make_Objects_Opaque. I'd like to use the last one as a manual but I was unable to reach everything I wanted.

$\endgroup$
3
$\begingroup$

The problem is that your clouds should not be in front of the island, but behind!

EDIT: (after messing with this for a while...) You need one more mix node. In other words you need one to key the clouds behind the island. And another one mix node to mix the mist over the island and the background.

NODES

enter image description here

I disabled mist again, according with your comment. The hardest part is controlling how the horizon meets the sky since the mist pass takes care of the island but not of the ocean in the distance, so I added a mask to affect the alpha channel at the horizon line of the render layers node. Then I used that new mask to control the alpha over that mixes the Island and the sky.

The modified file I placed here: http://www.pasteall.org/blend/28181

It's been a lot of fun playing with your file!

$\endgroup$
  • $\begingroup$ Welll, all this time I really couldn't get that my island is in the background, I thought the island itself becomes alpha-transparent, so clouds are visible. Now, I created smthng according to your advice-i.imgur.com/xfZFs35.jpg. At least island isn't transsparent now so much. I would like to know how to add mist if not connect it to FAC socket (well, I heard that trick from CgCoookie). Here is my current node set up-i.imgur.com/ugXg7tI.jpg. I know it's bad. This is my blender file, if you'd like to check it out - $\endgroup$ – Mr Zak Apr 2 '14 at 17:09
  • $\begingroup$ docs.google.com/file/d/0B2fE3q7fXpybN2FVLVVXb2g4dnM (^ link to .blend file). $\endgroup$ – Mr Zak Apr 2 '14 at 17:21
  • $\begingroup$ See the edited answer. I uploaded a modified file at: pasteall.org/blend/28114 $\endgroup$ – cegaton Apr 2 '14 at 19:08
  • $\begingroup$ Well, I highly appreciate your help, thank you very much. I will study those images and file you uploaded, sorry for being late, had some technical troubles. Still, as far as I can see from the image of your render, I would like to mention some things. First, I know that Mist isn't enabled in the world properties - it's because I used particles systems (not one, as you might notice) and in case of enabling Mist factor in the world settings with them emitter works wrong. $\endgroup$ – Mr Zak Apr 4 '14 at 22:22
  • $\begingroup$ Mist blurs them not according to the real rules, they (I mean those trees) blur in some fantastic way, too strong especially in the center and top. Second, island looks good (at last it isn't translucent!) but there are some troubles with very sharp horizon line betwen blue clouds and white mist in the distance. That's why I tried to mix them using those settings you could see, particularly by disabling Mist fac. I had tried similar way as you have done and it hadn't been good enough. I will continue my study of the problem and will share with my research as far as I can. $\endgroup$ – Mr Zak Apr 4 '14 at 22:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.