I am trying to assign multiple materials to an object (to different faces). I understand that I have to have multiple materials, and multiple material slots with these materials assigned.

However, I am having trouble creating a material slot in the first place. I select my object, then, still in object mode, I go to Materials tab, then press + on the right of the slot list (A). Nothing happens (i.e. no slot appears in the list) (B).

Blender Material Slots

I thought it might be that I have no material yet, so I pressed the "+ NEW" button below the slot list (C), created a new material, and with it still showing, clicked the + (A) on the right of the slot list again. Nothing happens (i.e. no slot appears in the list).

What am I missing here?

  • $\begingroup$ Are you using the Cycles rendering engine or the Blender internal? $\endgroup$
    – agiro
    Jun 25, 2017 at 8:38
  • $\begingroup$ By the way, if on Cycles, you add a new mat slot, create a new mat (if you wish) then go to edit mode in the mesh, go to face mode and select the faces you want the material to be assigned to, then you will see Assign, Select, Deselect. Click assign and you should be fine. $\endgroup$
    – agiro
    Jun 25, 2017 at 8:44
  • $\begingroup$ It doesn't seem to matter which rendering engine I use. As for the Assign/Select/Deselect: Yes, I see them; but as I don't have a material slot, clicking them doesn't do anything. $\endgroup$
    – Phil
    Jun 25, 2017 at 9:35
  • $\begingroup$ Is this object linked in from another blend? $\endgroup$
    – David
    Jun 25, 2017 at 18:09
  • $\begingroup$ @David no; it was however imported from a .stl file. $\endgroup$
    – Phil
    Jun 26, 2017 at 11:18

1 Answer 1


Phil, I add below a capture of how it should be behaving (both on blender render or cycles render): if it does not work like this, something went wrong, either the blender install itself or something else...

enter image description here

  • $\begingroup$ That is how I thought it should look like ;-) I now exported my model as an FBX, reimported it into a new .blend file, and there the material slot does indeed appear. Something seems to have gone very wrong in my first .blend file. Rather weird. Thanks, this helped! $\endgroup$
    – Phil
    Jun 25, 2017 at 9:56
  • $\begingroup$ When making a gif that includes button presses it would be a good idea to include the mouse pointer. $\endgroup$
    – David
    Jun 26, 2017 at 12:29
  • $\begingroup$ @David I agree, I'm using LICEcap on linux (through wine) and I can't see the option... is it possible, how? $\endgroup$
    – m.ardito
    Jun 26, 2017 at 14:26
  • $\begingroup$ @David I just found key-mon (github.com/critiqjo/key-mon), it seems quite useful for tutorial-like screen recording... I'll try to update the gif video, tomorrow... thanks for pointing this out! $\endgroup$
    – m.ardito
    Jun 26, 2017 at 17:16
  • $\begingroup$ @m.ardito odd, I use licecap (on windows) and it captures the mouse pointer. $\endgroup$
    – David
    Jun 26, 2017 at 22:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .