1
$\begingroup$

I'm using Adaptive Subdivison Surface on a model and some sections of the mesh just dissapear when I go in render mode. I'm using the material Displacement mode to "Both". Also, I'm using Simple Subdivision Surface Modifier.

Not sure what is happening. Googling didn't return any useful results, either. Is the topology somehow affecting the hiding?

Solid Mode: enter image description here

Rendered mode: Rendered -- Parts Of Mesh Culled

$\endgroup$
  • $\begingroup$ check your normals, is does look like half of your mesh is inside out, but that still doesn't explain your issue. $\endgroup$ – David Jun 25 '17 at 18:05
  • $\begingroup$ Yeah. That was my initial assumption. I had aligned all normals externally and I even visually confirmed all were pointing outwards. However, I still faced the same issue when moving over to the rendered view. $\endgroup$ – Arklumen Jun 25 '17 at 18:11
0
$\begingroup$

It seems that the problem is related to the ngons the mesh has. Convert them to quads and try rendering again. Also, it seems that this only happens when the shading is flat.

$\endgroup$
  • $\begingroup$ The smooth shading worked. Converting to quads didn't do much. So, does it mean flat shading will not work with adaptive subsurf mods? $\endgroup$ – Arklumen Jun 25 '17 at 5:03
  • $\begingroup$ Adaptative subdivision and flat shading works for me, but I get holes or missing faces with ngons and flat shading. $\endgroup$ – Matt Ferndz Jun 25 '17 at 6:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.