2
$\begingroup$

I have a model on which I want a patch of PNG texture but the rest of the model has no texture. What I want to achieve is:

Where the texture is not transparent - render the texture

Where the texture is transparent - render the material

Where no texture is defined - render the material

I can get the texture to show up in BlenderRender-view by turning on the material's 'face textures' option (having UV-mapped the faces that are to be textured) but this seems to turn off the material color (and I just get grey where there is no texture and black where the texture is transparent - presumably the texture is set to black under the transparency in the PNG).

Probably either something simple or I am taking entirely the wrong approach.

model in blender with texture

$\endgroup$
1
$\begingroup$

Quite easy. After you set up your base material (in my case a blue color) go over to the Texture tab.

Add in the texture (it doesn't even need to have an alpha channel).
Now set the Image Mapping to Clip, if you don't the image will tile all over your object. (Do note that the clip option does not work with the Texture or Material shading in the 3D view, you have to be in rendered mode.)
Set the Mapping to UV, it is one of the easiest ways to do a decal type of texture.
Last, do not have this texture influence the alpha at all. The only thing this texture should Influence is the Color.
texture settings

That's it. Where the texture is, and is not transparent, the texture is displayed; everywhere else the material is displayed.

rendered material
This is what my material with the texture settings above looks like. The blender logo is a png with an alpha channel, the blue is from my diffuse color in the material.

$\endgroup$
  • $\begingroup$ Thanks. I knew it would be something simple! Alpha is not Alpha! Of course! :-P All is working now, thanks greatly. :-D. $\endgroup$ – LaeMing Jun 26 '17 at 7:47
0
$\begingroup$

A little more fiddling with the advice from @David above and these settings are working for me now:

enter image description here

I got the black square to go away by turning off the Use Alpha but the material still didn't come through :-( .

Turning on Use Alpha in the Image panel, then also Alpha:Use in the Image Sampling pane seemed to do it.

(I may have randomly clicked on other stuff, but I think I un-clicked everything that didn't turn out relevant, again!)

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.