11
$\begingroup$

The question is how can I exclude an object from the freestyle render?

What I need to do is create a Clay render with the wire only on the airplane.

My scene is simple I only have two objects the "Toy Plane" and the "floor". For the Clay render I only override the materials to a simple clay material and done. Viewport
SimpleClay

But this happens when I use freestyle. How can I tell freestyle to ignore the "Floor"?

render with freestyle

$\endgroup$
  • $\begingroup$ I never used freestyle, but you talk about the wireframe modifier but you dont tell us why you dont use this solution. This tutorial could help you if this kind of render fits your needs: How to Render a Wireframe $\endgroup$ – Pyros Jun 25 '17 at 0:14
12
$\begingroup$

So you want freestyle on the plane but not the plane :)

This is very easy to do. Add the plane to an object group. Select it and press CtrlG.

Now in the Scene tab of the Properties panel scroll down to the "Freestyle Line Set" section, and add Group to the "Selection By:" setting. (outlined in red in the image below)
freestyle settings

Set the group you made earlier as the "Group" (the group field will be on the bottom).
Now depending on which plane you grouped, click the "Inclusive" box if you grouped your airplane; because you want to only include objects in the group in this freestyle lines. Conversely if you grouped the ground plane click the "Exclusive" box, to exclude the ground plane from freestyle.

$\endgroup$
  • $\begingroup$ Thank you David this works. So you cannot exclude objects this is only possible using groups and a group can have multiple objects. $\endgroup$ – Hammerh5 Jun 25 '17 at 16:00
  • $\begingroup$ yes, kind of. This is the simplest way to do it, but you could use different render layers, or using "Face Marks". But there is no way to just say "only render lines on this object" or exclude this object. Closest thing is a group with one object in it. $\endgroup$ – David Jun 25 '17 at 17:01
1
$\begingroup$

Addding to the previous answer, if you want to avoid using Groups, under Edge Types uncheck all checkboxes except Edge Mark. Then to freestyle a particular object, go to it's Edit mode, select all edges. Then Mesh -> Edges -> Mark Freestyle edges

This would apply freestyle only on edges that are marked. Worked for me... :)

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.