0
$\begingroup$

enter image description here

Hello all,

Apologies for the bad title. I am very new to this! Basically I spent a while creating this model, and then after following a texturing turtorial, I have ended up with this mess. I wanted to check that the UV map does actually work. So I just filled my UV map with green, however my model isn't completely green? Why is this and how can I fix it??

Thank you.

$\endgroup$
  • 2
    $\begingroup$ The texture shaded mode it surely overlaying the default shading of the faces to the texture if you don't enable "shadeless" option. That said, there may be other things involved (wrong normals orientation, multiple materials...) Could you show your object also in solid mode view? $\endgroup$ – Carlo Jun 22 '17 at 16:48
  • $\begingroup$ Where can I find this shadeless option and what does it do?? Also here is a link. I hope it works! imgur.com/a/mxK1q $\endgroup$ – Kieran Jun 22 '17 at 17:00
  • $\begingroup$ Definitely something off with your normals. Try this: blender.stackexchange.com/questions/18886/… $\endgroup$ – Lukas Valine Jun 22 '17 at 17:33
  • 2
    $\begingroup$ Have in mind that you seem to be confusing a lot of different concepts. Your UV Map is not green, your texture is. UV maps don't hold color information. There is no material applied to your mesh unwraping ≠ texturing ≠ materials. Unwrapping your mesh doesn't give it color, UV maps are not materials, and textures can't be applied by themselves to an object, they need a material $\endgroup$ – Duarte Farrajota Ramos Jun 22 '17 at 17:43
  • $\begingroup$ @LukasValine I have recalculated my normals, but some faces are still black. Even if I flip the normals on those faces, they remain black. $\endgroup$ – Kieran Jun 22 '17 at 17:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.