27
$\begingroup$

I have been trying to create a transparent lens using the eevee rendering engine in 2.8 but the transparency slider has no effect. Has this feature not been implemented yet? I've looked all over the Web for an answer with no luck. I'm a noobee so am probably doing something wrong.

$\endgroup$
  • $\begingroup$ Blender 2.8 is under heavy development, it is not feature complete nor ready for testing, even less production work $\endgroup$ – Duarte Farrajota Ramos Jun 21 '17 at 18:07
  • 5
    $\begingroup$ I'm voting to close this question as off-topic because it is about an incomplete development version of Blender $\endgroup$ – Duarte Farrajota Ramos Jun 21 '17 at 18:08
  • 1
    $\begingroup$ Albeit Eevee is in heavy development Transparency was added just some days ago. I try to make videos of the progress of Eevee, you can watch some of the videos on youtube. youtube.com/watch?v=TMmJuIxOCB8 $\endgroup$ – martinlindelof Jul 13 '17 at 17:52
  • 1
    $\begingroup$ Here is a video where he uses the alpha image and the transparency node with the principled bsdf. Check this video- google.com/url?q=https://m.youtube.com/… $\endgroup$ – Marshal tudu Jun 14 '18 at 8:58
  • 2
    $\begingroup$ Recommended reading: Cycles vs Eevee, 15 limitations on real time rendering $\endgroup$ – user1853 Jul 8 '19 at 13:34
36
$\begingroup$

Use these settings:

  1. Render → Screen Space Reflections - On
  2. Render → Screen Space Reflections → Refraction - On
  3. Material → Surface → Principled BSDF → Transmission - $1.000$
  4. Material → Surface → Principled BSDF → Roughness - Adjust to your needs
  5. Material → Settings → Blend Mode - Opaque
  6. Material → Settings → Screen Space Refraction - ON
  7. Material → Settings → Refraction Depth - Adjust to your needs, I generally suggest $0.8$ but depends on the thickness of the object.

Result:

enter image description here

(It's quite similar to Albert's answer but different)

| improve this answer | |
$\endgroup$
  • $\begingroup$ Where are these settings in the latest beta? $\endgroup$ – jdk1.0 Apr 3 '19 at 8:09
  • $\begingroup$ I'm confused. Why does transparency work with blend mode set to opaque for the principled shader but needs blend mode set to alpha for transparent and other shaders? $\endgroup$ – ecv May 12 '19 at 19:46
  • $\begingroup$ I don't think this is a truly transparent effect. I just tried it, there's somehow some strange refraction going on which when you look straight through it it looks as if you can see what's behind, but somehow it doesn't feel right. $\endgroup$ – ecv May 12 '19 at 20:03
  • $\begingroup$ It does not look right because of the way eevee fakes transparency. I just added the last setting to the list. "Refraction Depth" allow you to tell eevee how thick the object is. (If it's set to 0 there only is one refraction event otherwise 2). To understand this watch this video youtube.com/watch?v=VB5kMlW2EBI (time: 17:00) from Blender Guru $\endgroup$ – strategaD Jul 5 '19 at 15:18
  • $\begingroup$ I also found that accidentally setting IOR<1 would break transparency. IOR=1 is completely thin, clear glass and higher values give thicker glass. But less than 1 and it breaks $\endgroup$ – Eldamir Jul 30 at 4:28
20
$\begingroup$

I succeeded in getting EEVEE viewport transparency to work in the following way:

  1. In the Material activate Use Nodes, switch to the Shading layout so you can see the material nodes easily. Add a Transparent BSDF shader and a Mix node. Link the existing Principled Shader and the Transparent BSDF to the input side of the Mix node, and the output of the Mix node to the Surface input of the Output node.

  2. Adjust the Fac setting of the Mix node to determine the amount of transparency.

  3. However, notice that you see transparency in Cycles, but not in EEVEE, until under Settings of the material, switch Blend Mode to Alpha Blend or one of the other Alpha options. While it remains in its default setting, Opaque, the material will not be transparent.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Oh man, thank you! This is a solution for a transparent cloud layer over Earth etc, by using an image texture set on non/color data and linking its color to the Principal Shader and Fac of the mixing node. $\endgroup$ – Lumis Feb 9 '19 at 14:54
9
$\begingroup$

Change Blend Mode under Materials tab for transparency.

Check the Screen Space Refraction for glass materials, also not forget to turn on them at render settings tab.

enter image description here enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ You sir are awesome! $\endgroup$ – Prime By Design Aug 16 '19 at 17:10
4
$\begingroup$

I found that a mix of Mike Robinson's and strategaD's answers works best for me. Thanks to both.

That is:

  1. Render → Screen Space Reflections ON
  2. Render → Screen Space Reflections → Refraction ON
  3. Material → Principled BSDF and Transparent BSDF into Mix shader
  4. Material → Principled BSDF → Transmission 1.000
  5. Material → Mix shader Fac mostly all the way to Transparent
  6. Material → Settings → Blend Mode Alpha Blend
  7. Material → Settings → Screen Space Refraction ON
| improve this answer | |
$\endgroup$
4
$\begingroup$

Eevee treats transparent objects differently than Cycles. They are sorted from front-to-back per object and do not receive any screen space effects.

This is fast and works fine for many cases, but it is only approximate and gives incorrect results for some object shapes. For more accurate results, enable Alpha Hashed transparency in the material. With a sufficient number of samples to resolve the noise, this gives accurate transparency.

| improve this answer | |
$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.