1
$\begingroup$

I have a PBR material with a normal map for some surface defects. I'm trying to use Displace to emboss some fonts but I'm just getting an outline instead of full depth.

Reference image:

Ref Image

Node set up:

Node Set Up

Texture: (this is cropped the original is 2048x2048) Also, I've tried many combinations black on white/middle grey/alpha etc.

Texture

Mesh:

Mesh

Result:

Result

$\endgroup$
9
  • $\begingroup$ Can you show your source texture? $\endgroup$ Jun 21, 2017 at 12:37
  • $\begingroup$ Yes, I had it ready to go and forgot... Thanks! $\endgroup$
    – Dontwalk
    Jun 21, 2017 at 12:45
  • $\begingroup$ Are you using experimental Microdisplacement? $\endgroup$
    – cgslav
    Jun 21, 2017 at 12:59
  • $\begingroup$ No, I read threads on it here and decided not to. But I am open to anything. $\endgroup$
    – Dontwalk
    Jun 21, 2017 at 13:04
  • $\begingroup$ Switch on the "experimental" feature set, then in the material settings, change the displacement from "bump" to "true" or "both". blender.stackexchange.com/questions/45873/…. Alternatively you can use the displace modifier, which will give you more nuanced control. $\endgroup$
    – user1853
    Jun 21, 2017 at 13:17

1 Answer 1

2
$\begingroup$

Add a glow effect in 2D editor like Gimp or Photoshop:

enter image description here

Next, create normal map using this image (in GIMP - normal map plugin)

enter image description here

Normal map gives mach better result:

enter image description here

$\endgroup$
2
  • $\begingroup$ Thanks, but how does this solve my problem of the outline result that I am getting? $\endgroup$
    – Dontwalk
    Jun 21, 2017 at 13:14
  • $\begingroup$ You have outlines because edges is to hard, I think. Add softness and use normal map instead of displacment $\endgroup$
    – Crantisz
    Jun 21, 2017 at 13:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .