1
$\begingroup$

I am trying to create a cloud of dust, and the volume scatter is creating a large amount of fireflies. However, unlike the other posts I've read, increasing the samples creates more fireflies, and as the accumulate, they create shiny, reflective spots around the edges of my mesh. I have a single spotlight and a blue background to light up the volumetric mesh, and changing lighting features such as "Casts Shadows" and "Multiple Importance" seems to have no effect.

Here's an example of the problem with 50 samples:enter image description here

one with 200:

enter image description here

and finally one with 500

enter image description here

As you can see the fireflies get more and more concentrated around the edges as the samples go up, and create weird highlights and reflections in the end.

I will note that I am an advanced Blender user, and I am very familiar with eliminating fireflies, but these ones seem to defy logic. I've never seen a problem like this. Any help would be appreciated. Thanks, Graves.

$\endgroup$
1
$\begingroup$

Try increasing and decreasing the size of your spot light, to see its effect.

Consider adding a large plane with emissive light settings and a "go between" opaque plane with a hole in it to substitute for a spot light.

Also consider setting your rendering "clamp indirect" to 0.1 or 0.2 to clean up the fireflies.

$\endgroup$
  • $\begingroup$ I found a work around for the problem, but thanks for your answer! $\endgroup$ – Zacocast Jun 21 '17 at 22:08
  • $\begingroup$ Please share your solution for the benefit of others that will find this post in their search. $\endgroup$ – user2511 Jun 23 '17 at 19:32
  • $\begingroup$ Sorry, I'm kinda new to this forum, I didn't know I should post my solution. Alright $\endgroup$ – Zacocast Jun 24 '17 at 2:25
1
$\begingroup$

In the Render tab and under Light Paths, try increasing the Max Transparency, or the maximum number of mesh walls that can be transparent before returning any further polygons to a solid color. I do believe this fixes the problem even with an opaque film:

enter image description here

$\endgroup$
0
$\begingroup$

I found a work around for my problem. It appears that when the film is set to transparent this isn't a problem. It still seems like a strange problem, and this solution won't work for everyone, because I'm sure most people use opaque film. But others who stumble upon this problem may want to try this answer!

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.