6
$\begingroup$

I have a problem where I used physics to position a bunch of meshes in Blender and when I try to set the current frame to 0 it resets the position of the meshes that have been positioned with the use of physics.

Here is the blend file.

Here is what the positioning looks like (Frame 300):

enter image description here

Here is what the positioning looks like after I try to set to frame 0 (Frame 0):

enter image description here

$\endgroup$
  • $\begingroup$ Can you please upload your blend file? $\endgroup$ – Thom Blair III Mar 30 '14 at 1:57
  • $\begingroup$ Where would you like me to upload it to? $\endgroup$ – Dima Mar 30 '14 at 2:01
  • $\begingroup$ Many people use pasteall.org and I use drive.google.com. $\endgroup$ – Thom Blair III Mar 30 '14 at 2:08
  • $\begingroup$ Here you go pasteall.org/blend/28020 please try and figure out what the problem is. $\endgroup$ – Dima Mar 30 '14 at 2:16
  • $\begingroup$ Ok, so just to make sure I understand correctly: you want the bunch of meshes to be all down in the box at frame 1? $\endgroup$ – Thom Blair III Mar 30 '14 at 2:19
4
$\begingroup$

The objects' positions get reset because, by clicking on frame 0, you are "going back in time" to the beginning of the animation.

To use the rigid body physics to set the initial positions to be what they are at frame 300, here's one method:

  1. Select all of the objects involved in the rigid body physics simulation
  2. Bake to Keyframes (in 3D View window, hit T, then select Physics > Bake to Keyframes)
  3. Still with all the objects selected, open the Graph Editor
  4. All the keyframes should be selected already. If not, hit A.
  5. Move keyframes back 300 frames (Gx-300).
  6. Erase all keyframes (DeleteEnter).
| improve this answer | |
$\endgroup$
  • $\begingroup$ Thank you so much!! Exactly what I needed! Cannot thank you enough, my hero :) $\endgroup$ – Dima Mar 30 '14 at 7:20
  • 3
    $\begingroup$ Thanks! In Blender 2.8 one clicks on Object menu then Rigid body > Bake to keyframes.. $\endgroup$ – Lumis Mar 19 '19 at 17:40
16
$\begingroup$

Apply Visual Transform

Another way to solve this problem without the need to bake is to use Apply Visual Transform like this:

  1. Go to frame 300 and select all the mesh pieces

  2. CTRLA -> Visual Transform

    enter image description here

Applying Visual Transform will set the Location, Rotation and Scale of all the selected objects to what they are on frame 300.

With this method, you don't need to bake the simulation and you also don't loose the rigid body settings.

Credit for this answer goes to sergof here on StackExchange.

| improve this answer | |
$\endgroup$
  • $\begingroup$ I tried this in Blender 2.8 and does nothing, while the bake to keyframes works $\endgroup$ – Lumis Mar 19 '19 at 17:38
  • $\begingroup$ In 2.8 this still works. Just remember to Remove the Rigid Body from the objects after you Apply Visual Transform. $\endgroup$ – Keith Pinson Apr 23 at 14:19

Not the answer you're looking for? Browse other questions tagged or ask your own question.