Fresh cube mesh was added, and shaped into a rectangular shape. Dark blobs appear to be showing when the mesh is selected in edit mode, zoomed in enough, and with the subdivision view to 2.

enter image description here

When object mode is selected the blobs disappear and the mesh appears normal.

enter image description here

Also, when zooming out enough, the dark blobs begin to disappear.

Is this a graphical glitch, or is this a problem with the mesh itself? The mesh is very new, just pulled faces and extruded 2-3 times. Thanks!


It's perfectly ok.

You are seeing it because mesh after using Subdivision Surface modifier cross boundaries of your low poly model and those have color with very low opacity but still visible.

Also they are dark because of your selected Blender theme which is if I'm not wrong 'Graph'.

If you don't like this appearance you can always switch to different theme.

enter image description here


No, there is no problem with the mesh, or with your computer, .What you see in edit mode is the effect of the subsurf modifier being displayed in edit mode, but without shwing the full result of the deformation.

If you want a full representation of what the subsurf modifier is doing in edit mode enable the triangle icon.

(form the Blender Manual):


When enabled, the final modified geometry will be shown in Edit Mode and can be edited directly.

enter image description hereenter image description here


First, these dark blobs exists because of the sub-divided mesh is poking through its editing cage. It's perfectly safe.

Second, if you want to see your editing cage behind the blob, try this:

The button on the bottom right will make your editing cage visible even behind your object.

Limit selection to visible, turn it off

  • 1
    $\begingroup$ Limit Selection to Visible, if you meant, will make actual mesh geometry to be either hidden or visible; this won't change modifier's behaviour $\endgroup$
    – Mr Zak
    Jun 18 '17 at 21:02
  • $\begingroup$ Nobody asked about modifiers. $\endgroup$
    – TeaCrab
    Jun 19 '17 at 10:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.