2
$\begingroup$

I'm having trouble baking textures: I want to bake my textures, since I'm making a simulation out of them, so I can't just render the entire scene.

I set up my UV Map and unwrapped the materials using the Smart UV Project option. I included the nodes in the pictures below just in case that might help.

So after the baking was finished, the actual texture seemed a whole lot darker than the render, as well as the shadows seemed misplaced. The scene looks like the one on bottom left:

enter image description here

However, in the texture viewport, the scene oddly looks like this one at the bottom left:

enter image description here

In my bake settings, everything is checked except Selected to Active and Cage, with a margin of 16 px.

Is there something I'm doing wrong? I appreciate anyone's help in advance.

NOTE: This happened to all of the materials, I'm just showing the Dark Green material out of the 14 materials I have in this model.

$\endgroup$
  • $\begingroup$ Are there any objects in your scene visible to viewport but unrenderable, like light sources? Also check you terrain normals are pointing outwards $\endgroup$ – Duarte Farrajota Ramos Jun 16 '17 at 23:44
  • $\begingroup$ I'm using a sky texture in my World Settings that lights the scene, and an additional sun lamp. I just checked my normals which all seem to be fine. $\endgroup$ – Squirrel Jun 16 '17 at 23:57
1
$\begingroup$

First of all, you need to apply scale and rotation to all your objects

shift + a

You can't have any scales that are negative, also this is just a general practice I would advice you before rendering. Note that sometimes you have to check if your object face normals are not inverted after applying a negative scale.

My computer has issues rendering right now but this was my result:

my result

I also set the sun strength to 2.5, but that is up to you of course.

$\endgroup$
  • $\begingroup$ It worked! Also, I discovered earlier that part of the reason it wasn't working too well was because some polygons were overlapping each other, but even after I fixed them it still wasn't perfect. This seemed to fix the issue. Thanks! $\endgroup$ – Squirrel Jul 21 '17 at 1:26
  • $\begingroup$ glad to help :) apply scale & rotation will be your best friend $\endgroup$ – Madlaina Kalunder Jul 21 '17 at 8:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.