0
$\begingroup$

I baked the normals of a high poly mesh to a low poly mesh using cycles but the result seems somewhat odd.

This is how the low poly mesh looks like with baked normals: lprender

This is the high poly sculpt: hpsculpt

This is the normal map: normal map

The cage is a duplicate of the low poly mesh with a displacement modifier applied. All three objects are in the same location. Low poly does not share UVs. Shading is set to smooth.

How can I get the normals right?

Here is the .blend file:

Update: Since it was suggested that this issue occurs because of the difference between high and low poly I made a new subtle sculpt but the error still is present:

new subtle sculpt

$\endgroup$
  • $\begingroup$ What is the setup for the normal map? Is there only one object on the first screenshot but not two overlapping? The objects also look quite different which can be a problem for normal map but probably not related exactly for this problem. $\endgroup$ – Mr Zak Jun 16 '17 at 21:26
  • $\begingroup$ If you refer to the node setup it is: Image Texture > Normal Map > Diffuse BSDF > Output. It is just one single object. I've tested it with a more subtle sculpt and it still shows those brightened faces. $\endgroup$ – Shiro Jun 16 '17 at 21:36
  • $\begingroup$ I meant more details like screenshot, I know how to setup normal map in Cycles. Then let it be this: is your setup the same as in this answer? Ignore the bump map texture plugged in the Height socket, I'm asking about Image Texture and Normal map nodes (and specifically about Non-Color data option in the former). $\endgroup$ – Mr Zak Jun 16 '17 at 21:42
  • $\begingroup$ Yeah, they are exactly the same. I've imported it into the unreal engine, and it shows the same issues. $\endgroup$ – Shiro Jun 16 '17 at 21:46
  • 1
    $\begingroup$ In the case shown probably it's caused by too big difference between high poly and lowpoly, generally rough forms should be preserved. Hard to say more without the file (if it's possible you can upload it and edit the question with link) $\endgroup$ – Mr Zak Jun 16 '17 at 21:57
1
$\begingroup$

Previously I pointed it out that you didn't smooth the object. That's not the case, see update.

Update:

Your normal map is baked correctly.

I brought it to Blender Internal Render and this is the result.

Cycle has shading problem on lowpoly models. Whether you smooth it or not, it will be rendered as if not smoothed.

I previously missed that point, too. Your process isn't the problem. Cycle is.

enter image description here

$\endgroup$
  • $\begingroup$ "Shading is set to smooth." - Quote from question. $\endgroup$ – Shiro Jun 19 '17 at 15:32
  • $\begingroup$ I forgot to mention. Cycle always 'render' lowpoly model like that. Smoothed or not smoothed. $\endgroup$ – TeaCrab Jun 19 '17 at 15:44
  • $\begingroup$ Initially I didn't realize it. Cycle doesn't like lowpoly objects, and render them always as somewhat flat shaded. And I thought he didn't smooth it, which he did, it's cycle that tricked everyone. Apply a normal on those lowpoly under cycle render doesn't make them shade correctly. Had to bring the normal map into BI to realize the actual problem. LOL $\endgroup$ – TeaCrab Jun 19 '17 at 15:59
  • $\begingroup$ Thank you. It is indeed working now. In the Unreal Engine if you forget to flip the green channel you get similar results, so I guess maybe Blender Cycles interprets normal maps differently. $\endgroup$ – Shiro Jun 19 '17 at 18:03
  • $\begingroup$ That could be the issue. $\endgroup$ – TeaCrab Jun 19 '17 at 18:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.