This is my first time using Blender, so I hope this isn't too obvious.

I'm using Blender 2.76b (can't use the latest version due to the graphics card), and importing an .fbx of a city model (which I didn't create). When I've imported it, I can't see the model anywhere. I've tried translating it as it should be georeferenced to OSGB36, and rescaling it, however nothing is showing. The top of Blender is showing me a fair count of all the faces etc, so it would seem as though the import it working correctly. I've tried some of the different options for zooming to the feature (e.g. Numpad.), but it doesn't appear to do anything.

  • 3
    $\begingroup$ Probably the object is not selected, in that case it won't be zoomed in. Try opening Outliner editor and looking through objects shown there. Related blender.stackexchange.com/questions/31766/… $\endgroup$
    – Mr Zak
    Jun 14 '17 at 11:05
  • $\begingroup$ Thanks, I have it working now. I think it was because I was selecting a group of objects rather than an individual object. $\endgroup$
    – Tim R
    Jun 14 '17 at 13:05

There are multiple reasons that the object is not visible after importing.

  1. Check the outliner and see if there is an object. Also see if it's visibility is on.

  2. Make sure you are in the correct layer. To display objects from all layers in the 3D view, press the backtick key.

  3. The camera clipping planes must not be proper. If you are looking from the User Persp camera, press the N key and adjust the Start and End values for the Clip plane. If you are looking from a camera object, edit the clip start/end in the camera data properties.

  4. In most cases pressing SHIFT+C in the viewport should frame all the objects in the scene. Refer to point 2 if 1 and 3 still does not fix the problem.


Not the answer you're looking for? Browse other questions tagged or ask your own question.