10
$\begingroup$

I'm trying to create a mini-world with (among other things) trees on it. I have created an icosphere, modeled several trees and put them in a group.
Next I added a particle system to the sphere, and chose hair. In the "render" section I selected Group and the name of the group I created. As expected the trees show up but they're all oriented in the same direction, while I would like them to pop up just like the default hairs do (along the normal of the individual faces).
I tried fiddling with all kinds of settings, had them oriented in all kind of ways (e.g. towards the "north pole"). I also tried using the emitter instead of hair setting but without success as well.

$\endgroup$
  • $\begingroup$ David and gandalf3 thanks for your help! Much appreciated! Rotating the tree along the x-axis in edit-mode seems to be the crucial step I was missing, but it works now :) I tried to accept both your answers but apparently that's not possible? (I'm new here so I might be missing something ;)) $\endgroup$ – Jersebas Mar 28 '14 at 9:39
  • $\begingroup$ Welcome to the site :) Yes, you can only accept one. You can vote for as many as you want though. Feel free to take the tour or visit the help center if you have any questions. $\endgroup$ – gandalf3 Mar 28 '14 at 20:15
6
$\begingroup$

For your hair particle system, just click on the button Rotation in the render panel of the particle settings.

enter image description here

Then make sure your objects are pointing towards the X axis. Other wise all your trees will point out from your planet, but they will not be pointing up. enter image description here.

$\endgroup$
5
$\begingroup$

Try rotating the source objects instead of trying to correct the rotation in the particle settings.

Note that the particle position is based on the Object origin, so make sure your origins are at the bases of your trees.

By default object rotation will not affect particles, so either:

  • Rotate the tree objects in edit mode, or rotate in object mode (individual origins is useful for rotating multiple objects at once) and then apply the rotation (CtrlA)

    Without rotation enabled in the particle settings, it appears that objects are oriented with the +Y direction facing out (with rotation enabled it is +X).

    enter image description here

  • Rotate in object mode and enable rotation in Particle settings > Render (as already mentioned by David)

Result:

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.