2
$\begingroup$

I have searched the forums some and am still coming up short on fixing my issue :(.

I am just getting back into blender after a few years break and have already hit a snag.

To the point.

I created a character/walk cycle and set up a scene. I can render out a still image perfectly fine, but when I try to render out the animation, I only get gray images.

Scene Setup/Outline/Camera Settings/Render Settings

Above shows the image in object mode/rendered mode/ and the little OpenGL render active viewport button. I also have tried to show my settings and outline as best as possible.

Below is a split image. The top (red outline) is when I render out a still image (I stopped it mid render, just showing that it works fine) and the bottom part of the image shows when I try to render out the animation by selecting the animation button.

enter image description here

I have gotten the animation to render by impending the file in a new blend file, but would like to know how to fix it instead. I looked back at my earlier saves and they too are having the issue. I'm completely lost and would appreciate the help so much! I thank you kindly!

I also made sure there were no hidden objects that were blocking the view and made sure the clipping distance was completely fine for my setup.

EDIT

Added the .blend file

$\endgroup$
  • $\begingroup$ First screenshot shows rendering frame 1 , but animation shows frame 2. Could the camera or other object be somehow animated so in the current frame it is fine but when rendering from zero it is inside something? What happens if you render more frames of the animation, are they all grey too? $\endgroup$ – Duarte Farrajota Ramos Jun 7 '17 at 1:32
  • $\begingroup$ They just rendered so fast that my screen shot hit frame number 2 lol :) But yes, all the frames come out gray unfortunately :( $\endgroup$ – Foolish Jester Jun 7 '17 at 2:19
  • $\begingroup$ Read the folowing links that deal with possible causes for blank rendering: blender.stackexchange.com/questions/67490/… maybe one of them applies in your case. $\endgroup$ – cegaton Jun 7 '17 at 2:43
  • $\begingroup$ Just as a test, have you tried activating the global layers button? On your first screenshot it seems like you are currently using local layers. It's the button right next to the layers in the viewport. $\endgroup$ – aliasguru Jun 7 '17 at 4:53
  • $\begingroup$ aliasguru yes, global is already activated but thank you for the suggestion! @cegaton I tried my best to go through the list and make sure those factors didn't contribute to my issue but I'm not sure if I missed something. I'll post the .blend file here soon when I can figure out how. I edited my original post to now include the .blend file. $\endgroup$ – Foolish Jester Jun 7 '17 at 12:11
0
$\begingroup$

By looking at your .blend file, I've noticed that your character is on layer 1, while your RenderLayer is set to render only layer 2.

Selecting layers 1, 2 and 9 in the RenderLayer "Scene" checkboxes I managed to have the animation work fine.

$\endgroup$
  • $\begingroup$ Omg... thank you so much haha. Something so simple. I honestly had to google how to find the RenderLayer tab, it's been way too long since I have used Blender. Thanks a million! $\endgroup$ – Foolish Jester Jun 7 '17 at 20:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.