I would like to use new denoising feature for cycles in blender. I downloaded latest build for blender (blender-2.78-81d7ff8-win64). When I open my project the option is present but grayed out, I can check it but it doesn't have any effect. Any idea which setting blocks this feature, where to look? I have quite complex scene and it is hard to find what is wrong. When I create new project the option is not grayed out and works.

enter image description here


2 Answers 2


You should uncheck the Progressive Refine option (Under the Performance render properties panel) in order to enable and tweak Denoising settings for high quality renders.

Following are the details for this behavior.

Denoising is a post processing pass after the render tiles and layers are finished. It tries to remove fire flies and other noise by utilizing rendered data. It works best when there are enough samples rendered and saved in render buffers.

The progressive refinement display of an ongoing render is an interactive feedback tool and since it is not used for final renders but for quick turnaround renders for fine tuning wip settings, the denoising feature is disabled.

Denoising and Render Layers in Blender

  • $\begingroup$ I dont have the panel showing at all? do I need to enable it or something? $\endgroup$
    – Alldaron
    Commented Jun 9, 2017 at 20:07
  • 2
    $\begingroup$ @Alldaron Currently, this feature is only available in the daily Blender builds (which contain experimental features and are unstable). It will be in the 2.79 release, which is currently in beta. $\endgroup$ Commented Jun 9, 2017 at 22:25

Ok, I found the answer. It turns out to be "Progressive Refine" option under Performance in Render tab. It should be unchecked.

enter image description here


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .