3
$\begingroup$

I'm having trouble getting Volumetrics to respond to the World environment lighting. I'm using a standard node setup combining Volumetric Absorbtion and Volumetric Scatter and it appears to work as expected for standard Lamps and also for Mesh lights but not for the World lighting?

There is a checkbox on the World Ray Visibility to control visibility for Volume Scatter rays and that appears to have no effect (see the checkbox being flipped in the right-hand panel but no effect on Suzanne) :

changing ray visibility

To show that this is working for standard (point) lamps and for mesh lights but not for environment lighting :

testing various lights

The sequence in the above image is all on, lamp off, lamp on, mesh off, mesh on, environment off, environment on. You can see that the lamp affects the suzanne volume, the mesh affects the suzanne volume, but the environment does not affect the suzanne volume.

What am I missing here?.... Or is this a bug?

I've tried this on Blender 2.76b and 2.78a with the same results.

$\endgroup$
  • $\begingroup$ I'm not sure, but is this not the same limitation that makes Sun Lights not work well with World volumetrics? Since they are considered to be at an infinite distance nothing ever gets through the volume density. $\endgroup$ – Duarte Farrajota Ramos Jun 6 '17 at 18:07
  • $\begingroup$ I don't think so as with world volumetrics the volume is covering the entire (infinite) distance from the sun - so it makes sense that it wouldn't get through. In this case there's nothing between the (infinite distance) light source and the edge of the mesh so it shouldn't be affected. The environment light affects a diffuse mesh alongside it as you'd expect but the volumetric material just doesn't get affected. $\endgroup$ – Rich Sedman Jun 6 '17 at 19:00
  • $\begingroup$ I see, you are right. Possibly a bug then, maybe worth reporting to the devs $\endgroup$ – Duarte Farrajota Ramos Jun 6 '17 at 19:11
2
$\begingroup$

I've managed to get this working - the problem only occurs when Surface Multiple Importance Sampling is not enabled for the World.

Here I have two Suzannes - one with Diffuse (the one on the Right) and one with Volumetrics to mimic the diffuse (with the Diffuse at 20% grey to produce a similar shading).

With Multiple Importance of the World disabled (the default) the volumetric material ignores the (red) World illumination :

Multi-Importance off

With Multiple Importance Sampling of the World enabled, the volumetric material is correctly illuminated by the world :

Multi-Importance on

Also, with Multiple Importance enabled, the Ray Visibility works as it should - enabling and disabling the effect on the volumetric scatter.

I don't know enough about the Multiple Importance Sampling to know if this is expected behaviour or what the downsides of enabling Multi-Importance (if any) are, but it fixed the problem for my situation.

$\endgroup$
  • 1
    $\begingroup$ Tou should usually have MIS enabled anyhow. It increases computation time but almost always makes up for it by requiring less samples. $\endgroup$ – PGmath Jun 7 '17 at 0:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.