1
$\begingroup$

enter image description hereApologies for not using the correct terms, but I am new to Blender and even though I searched a lot I cannot find the answer to my question.

I have imported an svg file into Blender and want to extrude each path individually, as I am interested in controlling the heights. Generally, I am planning to extrude each part individually and then convert to mesh.

I cannot seem to find how to extrude only to one direction on the Z axis. Whenever I extrude, the shape is extruded to both directions of the Z axis. Hope the above description makes sense.

Thanks.

$\endgroup$
  • $\begingroup$ You could duplicate the imported object, then remove from each copy all but one single part. Then you could extrude them individually. Or, you could convert the imported "curve" to mesh (ALT-C) then extrude selected vertices/edges/faces individually is possible. $\endgroup$ – m.ardito Jun 5 '17 at 14:28
  • $\begingroup$ Some screenshots of the curve would help. It could be that you use Extrude option of the beveling of the curve; in that way it won't allow extruding only in one direction. $\endgroup$ – Mr Zak Jun 5 '17 at 14:46
  • $\begingroup$ Probably I should clarify that I have imported the SVG file and managed to extrude the individual paths already. I haven't converted to a mesh yet. the problem is that I do not want part of the extrusion to appear on the bottom of my surface as I am making a kind of relief. Could what Mr Zak says be the problem? That I am applying the extrusion of the bevelling of the curve? I am uploading a screenshot as well, in case that helps. $\endgroup$ – mel_s Jun 5 '17 at 15:07
  • $\begingroup$ Thank you Duarte but I had already checked all these. I do not think that there is a problem with my geometries. The problem is that I cannot manage to make the extrusion happen to one side of the Z axis or make all extruded curves 'sit' on the same level/ground. $\endgroup$ – mel_s Jun 5 '17 at 21:39
1
$\begingroup$
  • In object mode, Select your SVG imported object
  • Press ALT + C and select: Mesh from Curve/Meta/Surf/Text
  • In Edit mode, press A to select all
  • Press E to extrude, press Z to lock onto that axis
$\endgroup$
  • $\begingroup$ Nice, but putting some example images would help others to better understand... $\endgroup$ – m.ardito Jul 20 '18 at 12:54
0
$\begingroup$

If I got what you mean, since your imported svg is already extruded, you could instead need to scale the shape using the "3d cursor" as pivot mode, it is nothing specific for an imported svg, it happens with any mesh.

here is the basic standard cube:

enter image description here

if you scale on global Z, scaling acts both on +Z and -Z

enter image description here

this happens because of the (default) pivot mode: median. You need to place the 3d cursor to the point you can control (eg: the base of the shape) and then change pivot mode to "3d cursor".

in (wireframe) side view select all the bottom veritces of your shape

enter image description here

then move the 3d cursor to "the selection"

enter image description here

you'll end up with something like this

enter image description here

then, change the pivot mode to "3d cursor"

enter image description here

and now the Z scale behaves like you wish

enter image description here

Hope it helps...

$\endgroup$
-1
$\begingroup$

Select the vertices/edges/faces you want to, press E to activate Extruding, then press press Z to change the direction of the extrusion to the Z-axis.

$\endgroup$
  • $\begingroup$ That should also include clarification that if a face is selected pressing Z after extrusion will in fact turn off any axis alignment as when extruding faces it will be locked to face normal by itself. $\endgroup$ – Mr Zak Jun 5 '17 at 14:42
  • $\begingroup$ Also, SVGs get improted as curves, extruding curves is different. Pressing E to extrude only works on mesh objects. Extruding is done on the geometry controls for the curve. The question states that the goal is to extrude before converting to mesh $\endgroup$ – cegaton Jun 5 '17 at 15:35
  • $\begingroup$ Yes, cegaton that is correct. The alternative option would be to extrude the curves and then convert to mesh and then place them on a base, while constraining the movement on the z axis. Still haven't found a solution.. $\endgroup$ – mel_s Jun 5 '17 at 16:22
  • $\begingroup$ This does not work on curve objects, and/or requires converting to mesh first, which is a destructive process that should be avoided if possible. It also does a poor job at explaining that it should be used in mesh objects, in edit mode, and require a selection of faces first $\endgroup$ – Duarte Farrajota Ramos Jun 5 '17 at 18:38
  • $\begingroup$ Also make sure you "apply scale" (CTRL+A) to make extruding work as expected. $\endgroup$ – icYou520 Jun 5 '17 at 19:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.