0
$\begingroup$

So, I wanted to create a scene with smoke, but this time to render with my AMD GPU. As I saw in the "feature comparison" chart, it SHOULD be supported for AMD by now (2.78). What is happenning to me, the smoke is not rendered AT ALL. Not a single bit of it. With CPU, it would take about 6 minutes/frame for a 30 frames/second, 11 minutes long movie. It would take for ages to render it all in CPU, so that's why I want it so badly with GPU rendering. I could spare 60-70% of time with GPU, according to simple image renderings, with no smoke, so it should be the same case with smoke too. So to be clear: CPU render works 100%, so material setup must be good. In the same time, GPU render simply hides the smoke completely, which is quite annoying. I am using Cycles.

If it is a problem with my composition, could you tell me what I did wrong? Working setup

$\endgroup$
4
  • 1
    $\begingroup$ Which AMD GPU do you render on? They are still beta-testing support so probably on some cards something won't work even if it should. $\endgroup$ – Mr Zak Jun 5 '17 at 11:38
  • $\begingroup$ I render on an R9 280X $\endgroup$ – 505Legion Jun 5 '17 at 11:46
  • $\begingroup$ Is rendering speed up at all with the card? It was already mentioned but things likely changed although officially that card is kind of not supported according to its architexture. Also btw are experimental features enabled? $\endgroup$ – Mr Zak Jun 5 '17 at 12:39
  • $\begingroup$ It renders waaaay faster in normal cases, as it was mentioned as well. I tried it with Experimental as well, but did not do anything differently. $\endgroup$ – 505Legion Jun 5 '17 at 14:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.