1
$\begingroup$

I followed several tutorials on how to paint my model with texture paint. I've unwrapped the model and made sure I have a material and a texture. I have a node to place my new texture image on my mesh, and I placed that image on my UV map as well.my set-up

I have no idea what I've done wrong, but painting on the mesh and the UV map doesn't work.

$\endgroup$

closed as unclear what you're asking by Mr Zak, Scott Milner, cegaton, p2or, Duarte Farrajota Ramos Jun 22 '18 at 4:21

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • $\begingroup$ Where were you trying to paint? As is shown on your screenshot paint should work in the viewport editor, so to paint on the model itself. You'll see how the image changes in the UV editor. It won't paint on the image in the UV editor as it's set to non-editable mode. $\endgroup$ – Mr Zak Jun 4 '17 at 9:38
  • $\begingroup$ I tried painting directly onto the mesh as well as onto the UV map, but neither seem to have changed anything. I'll check editing mode in the UV editor though. $\endgroup$ – Wilko Jun 4 '17 at 11:58
  • $\begingroup$ It should've already working in the viewport window so checking in UV editor window won't change a lot. Check settings of the brush - Texture scroll, if there isn't any empty texture assigned, Stroke scroll if stroke settings allow painting to show up immediately, Curve scroll if curve preset allows brush to draw.. Or import new brush from default file. Also in the Slots tab check if there isn't any masking image assigned. $\endgroup$ – Mr Zak Jun 4 '17 at 12:05
  • $\begingroup$ Oh yeah, it was the brush, thanks for helping. $\endgroup$ – Wilko Jun 4 '17 at 14:47
  • $\begingroup$ Could you clarify what exactly wasn't correct with the brush? Also it would be helpful for others if you answer this question with some details like screenshots and several words of explanation of what went wrong. Thanks. $\endgroup$ – Mr Zak Jun 4 '17 at 18:01
1
$\begingroup$

I suffered from this same problem, When you select TexDraw as your brush it automatically selects a texture to draw with, in which case is usually the new black texture you made to paint on so everything is black and will never be anything but. Just clear the texture from the TexDraw brush and you're in business.

$\endgroup$
  • $\begingroup$ When selecting TextDraw brush (or any present for that matter brush in Blender) there won't be any texture assigned automatically. It will be assigned only if you open that Texture rollout and press New button (or select from list of textures). $\endgroup$ – Mr Zak Apr 10 '18 at 22:39
  • $\begingroup$ I searched for an hour before finding this answer. I'm amazed it hasn't been upvoted before. I don't know why it defaulted to this, but it wasn't my choice. It did that in 2.79 and 2.8. I am going to add this answer to the far more upvoted and visible blender.stackexchange.com/q/15301/7548. Maybe it will save someone else from the anxiety i had. $\endgroup$ – kim holder Jul 15 at 19:58
  • $\begingroup$ And you do this removal HOW? All I can do is add more and more brushes. I can't find any way to delete them. $\endgroup$ – Elliot Sep 13 at 19:55

Not the answer you're looking for? Browse other questions tagged or ask your own question.