2
$\begingroup$

I have a recorded video (recorded in obs), that has a running time of 28 minutes 56 seconds. When I watch the video in a video player (e.g. vlc) the last word of audio is at the 28:55 mark. When I import into blender, the running time of the audio and video track is 28:56 but the last word of audio occurs at 28:48 and then there's silence for the last 8 seconds.

This isn't a case of the audio and video channels being different lengths. I recorded at 30fps and imported at 30fps so they both are the same length.

Screenshot of audio/video channels

What could be causing this weird audio issue? Is it some sort of codec issue or variable frame rate issue perhaps?

$\endgroup$
4
  • $\begingroup$ Blender cannot deal with video streams recorded with variable frame rates. You would need to transcode in an external app to a fixed frame rate before importing to blender. $\endgroup$
    – user1853
    Jun 3, 2017 at 16:10
  • $\begingroup$ So I ran the video file through handbrake to make it a fixed 30fps and it still happened.... quite confused now. Was hoping that was the issue. Really hard to Google this issue since result is about the audio and video being different lengths. $\endgroup$ Jun 3, 2017 at 22:11
  • $\begingroup$ Are you sure is 30fps and not 29.976? $\endgroup$
    – user1853
    Jun 3, 2017 at 22:49
  • $\begingroup$ When I run it through mediaviewer I get this. Frame rate mode: Constant. Frame rate: 30.000 FPS $\endgroup$ Jun 6, 2017 at 4:08

1 Answer 1

1
$\begingroup$

Okay so I finally figured it out!

enter image description here

I thought this would have only mattered if the recorded video was defined as a variable frame rate video, and things were broken even after explicitly converting it to a constant 30fps. But lo and behold, I changed that setting to AV-Sync and everything works beautifully!

Hope this helps anyone else looking for the answer to this problem.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.