1
$\begingroup$

Windows 10 2.78c

I am using the video sequence editor to put together video segments for an event taking place tomorrow.

mp4 strips cause the VSE to run too slowly on my machine for it to be of any use to me, so I'm having to work with the MTS files from the camera and then switch the references over to the mp4 when I'm ready to render.

I had just finished that process for one segment when I discovered that opening that segment's .blend file immediately crashes blender. Running the debugger from the command line tells me that as soon as blender attempts to read this file it gets an EXCEPTION_ACCESS_VIOLATION. Although there's a slightly different file size in the mp4's .blend1 backup and the MTS versions, they also immediately crash blender upon attempts to open.

All of my other blends work just fine.

I cannot find an earlier version of the file in TEMP or Recover options. I have attempted opening the file with "Load UI" unchecked (still crashes). I reproduced this issue with this file on a completely separate machine running Window 7.

All four non-working versions of the "entervillains" blend files are at this link, as well as a working "intro-mpg.blend" for comparison's sake.

I am hoping that the file isn't just hopelessly corrupted or that there's some way for me to get the strip data off of it to keep me from having to completely rebuild that segment from scratch. Time is of the essence and I'm still working on the other segments.

$\endgroup$

closed as off-topic by Ray Mairlot, cgslav, Timaroberts, David Jun 24 '17 at 12:34

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

  • $\begingroup$ Have you tried appending the scene in a new file? Not sure if it will bring all data from sequencer though. $\endgroup$ – Duarte Farrajota Ramos Jun 2 '17 at 17:25
  • $\begingroup$ It also looks to me like this wouldn't bring in the sequencer data, but, regardless, I get the same error. $\endgroup$ – Jakeb Ladrey Jun 2 '17 at 18:34
  • 1
    $\begingroup$ It doesn't sound like a corrupted blend file, it sounds like a bug, where something in the setup of the blend file is triggering the crash, therefore there is nothing to recover as all the data is still there. You need to report it to the bug tracker. If it is fixed quickly you can then use one of the nightly blender builds that includes the fix. $\endgroup$ – Ray Mairlot Jun 2 '17 at 19:21
  • $\begingroup$ Submitted. developer.blender.org/T51706 $\endgroup$ – Jakeb Ladrey Jun 2 '17 at 19:52
  • 1
    $\begingroup$ Update: Someone opening that file on OS X and then saving it and sending it back fixed the problem for me. $\endgroup$ – Jakeb Ladrey Jun 3 '17 at 1:08