1
$\begingroup$

I'm trying recreate Ian McGlasham's "ALICE" fluid animation. In the process, I've been trying to adjust settings for the size of my fluid objects and also for the resolution of the domain object, so I want to bake the domain, see the result, adjust things accordingly, then bake again. However, after I bake the domain once, when I try to bake again, the baking progress bar appears and progresses, but the fluid and domain object do not merge to become the flowing liquid. I assume there is a "Free Bake" somewhere that I'm supposed to click on but I can't find it. In addition, if I just go and manually find & delete the fluid cache folder in my computer, the domain still won't bake properly. Also, I'm using 2.70.

To show what should happen when you click Bake, I made a simple demo blend with a small inner cube as the fluid and a big outer cube as the domain:

enter image description here

See how the domain and the fluid objects merge into the fluid mesh? That's what should happen, but that doesn't happen for me if I click Bake a second time.

Here's the layout of my scene:

enter image description here

Here's what happens when I try to bake a second time:

enter image description here

See how the domain and the liquid objects stay separate and do not begin to flow? They should, but they don't and I can't figure out how to get them to.

Here is my blend file.

Just as a side note, is it weird that one cube inside another cube requires 27MB of memory to bake, but the other more complex scene only requires 1.89MB?

$\endgroup$
  • $\begingroup$ maybe try playing back? Alt + A? $\endgroup$ – Vader Mar 26 '14 at 18:38
  • $\begingroup$ I just tried, but the fluid and the domain stay separate, unmoving. $\endgroup$ – Thom Blair III Mar 26 '14 at 18:43
  • $\begingroup$ @ThomBlairIII Have you tried to bake into different folders as described here: blender.stackexchange.com/questions/5328/… ? $\endgroup$ – stacker Mar 26 '14 at 20:44
3
$\begingroup$

This is because your setup is a bit weird.

First, make sure the fluid objects are enough large to be initialized as fluid volumes. To do so, you can Tab to edit mode and scale it Z, to have more volume at the beginning of the simulation. Beware to move the volume inside the domain, since the volume beyond the domain won't be computed. A good idea here would be to reset origin of both fluid objects to their respective centers.

Then, your obstacle object is not well configured:

  • Set the Volume initialization setting to Both because it contains both concave and convex surfaces.
  • It does not contain enough subdivisions, so the simulation is not so much accurate. You should add more edges to the height of the obstacle object (Tab to edit mode, then Ctrl + R over an edge, then mouse scroll to add more subdivs.)
  • You should also Recalculate the entire mesh's normals. (In Edit Mode, A to select all, then Ctrl + N)
  • As a side note, you added a Collision physics modifier for your obstacle object, which is useless here (even if it doesn't affect the fluid sim).

The amount of memory required for the simulation depends on the resolution you specify, for Final: (used for render) and for Preview:. The more resolution you give, the more memory the bake will take.

There is no "free bake" button, but you can specify the directory where Blender will store the simulation data (in the domain's Fluid dropdown, file browser at the bottom). By the way, if you re-click on the Bake button, it will erase the previous baked data while the simulation compute.

$\endgroup$
  • $\begingroup$ Anyway, I recommend you to use an "inflow" fluid type instead of a simple "fluid" for the two meshes that set the fluid volume, with a negative Z initial velocity. And, for a better result, you should also set the "Slip type" of your obstacle object to "Free slip". $\endgroup$ – Polosson Mar 26 '14 at 19:44
  • $\begingroup$ Regarding: "make sure the fluid objects are enough large to be initialized as fluid volumes" -- when I first baked the domain, the fluid objects DID flow properly, so does that mean that if left unedited, they will always be big enough to act as fluids? $\endgroup$ – Thom Blair III Mar 26 '14 at 19:50
  • $\begingroup$ Also, one of my main objectives with regard to the size of the fluid objects is to make sure that once the fluid flows down into the letters, it is not too deep. I am trying to recreate the "ALICE" video by Ian McGlasham (blendernation.com/2013/05/16/some-cool-fluid-animations) so I don't want the liquid to be too deep. So, if I need to make the fluid objects bigger so they can be initialized, how do I make the name mesh bigger? What exactly counts as "bigger"? Is it more subdivision or is it world scale? $\endgroup$ – Thom Blair III Mar 26 '14 at 19:55
  • $\begingroup$ Sorry I'll just speculate on this, I really don't know. Maybe the initial volume of the object must be large enough to be subdivided according to the resolution you specify. BTW, here is your file with inflow meshes and corrected. $\endgroup$ – Polosson Mar 26 '14 at 19:58
  • $\begingroup$ If you don't want it too deep, you can stop the inflow, by moving it outside the domain with two simple keyframes. $\endgroup$ – Polosson Mar 26 '14 at 20:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.