0
$\begingroup$

screenshot of keyboard in Blender

Each one of the faces has 20 vertices (I know that every face is actually made out of triangles), but shouldn't it have the same normals? Or maybe there is a way to access those "background virtual faces" and fix it? It also does show up in the render.

I've noticed that it only happens with smooth shading. (Isn't it supposed to make things smoother?) I think it's okay with just flat shading, but I still want to know what's up.

Edge split modifier seems to be a good solution.

$\endgroup$
  • 3
    $\begingroup$ Add an Edge Split modifier toyour mesh or turn on Auto Smooth in Object Data tab. $\endgroup$ – Duarte Farrajota Ramos May 30 '17 at 1:24
1
$\begingroup$

enter image description here

I solved it extruding and addind faces in every key

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.