12
$\begingroup$

Let me start by stating that I have just recently picked up Blender to use as a Video Editor. Given that my knowledge is limited on this software, I have came across an issue which I can not determine if it is from user error or if it is a bug.

The goal I have is to have a video sequence effect which is driven by an audio track. By this I mean, as the audio becomes larger/louder the video effect should become more pronounced.

Now, I have done the following:

  1. Created a new project.
  2. Deleted the default sphere.
  3. Created an empty sphere.
  4. Created a single keyframe on the empty sphere's Z Scale.
  5. Baked a sound to the F Curve of the empty sphere's Z Scale.
  6. Added the same sound file to the Video Editing Sequencer at frame 1 channel 1 and extended the animation stop frame to match that of the sound file.
  7. Added an image to the Video Editing Sequencer at frame 1 channel 2 and extended it to the same length.
  8. Added an Effect Strip: Color to the Video Editing Sequencer at frame 1 channel 3. I changed the color to red and set the blend mode to Multiply. I also extended it to the same length as noted above.
  9. I then created a driver for the Opacity of the Effect Strip: Color.
  10. I set the properties of the driver to take the value of the baked sound of the empty sphere's Z Scale.

When I scrub through on the timeline, I can see the desired results in the preview window. However, when I render the animation, whatever the value of the Empty Sphere's Z Scale was on the last scrubbed frame is what the effect uses on all (non scrubbed) frames. Notice in the following screenshot, that the driver is picking up the proper value's. I'll show a few screenshots of what I am referring to: no description

What is interesting to note is if instead of creating a driver for the opacity of the effect, I create a new keyframe and bake the sound to the keyframe graph, it will render exactly as the above screenshot shows, which of course is what I am looking to do BUT would really want to do this via a driver instead. The example here has led me to speculate that one of two things are true. Either I am doing it wrong or this is just a bug.

Here are two links to a couple renders. The first is rendered with the effect being driven by a driver linked to the Z Scale of the empty. The second is with the sound baked directly into the visual effect's opacity keyframes.

Effect with opacity driven by a driver linked to z scale of the empty

Effect with sound baked to it's opacity keyframe

Anyone out there know what I'm missing or care to throw me a bone?


Issue resolved

Thanks to everyone for the assistance and to user2859 for another possible workaround.

$\endgroup$
  • $\begingroup$ That's strange. I'd like to help, but it would be easier if you could provide a minimal complete example. There were a lot of steps taken here. Can you try to narrow down the problem? For example, try getting rid of the Bake Sound to F-Curve part - instead just animate your own empty and set up a driver. Still have the issue? Try setting up a driver between 2 objects instead of involving the VSE. $\endgroup$ – Garrett Mar 25 '14 at 6:29
  • $\begingroup$ I suspect that if you go through this, you will either discover the error yourself or be able to condense this question into 3 or 4 sentences, in which case more people will be happy to read it and help! $\endgroup$ – Garrett Mar 25 '14 at 6:30
  • $\begingroup$ I've had success with drivers in the vse in the past. But I haven't lately rendered or used a baked f curve. I've used noise and min max mods from an objects driver. Perhaps it a class issue? Why can't you start wiyh a key frame? Wait are you trying to drive from a driver? $\endgroup$ – David Mcsween Mar 25 '14 at 9:45
11
$\begingroup$

The problem is:

The scene isn´t updated because the sequencer ignores the scene when it´s not visible in the final output. We might consider this a bug/limitation or a feature. I´ll talk to the core developers. So of course drivers that depend on the values of a hidden scene don´t work as expected.

A workaround:

If you don´t use the scene for output, render the scene so that the output is pure white and add the scene in the sequencer on top of every channel and use multiply as blend mode. Of course this increases the render time a bit. The key point here is that the scene shows up one way or another in the final render.

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.