2
$\begingroup$

I´m using a lot of OPENGL render animation for the sake of the rendering time, some motions quite simple that doesnt need any kind of raytrace like this one: enter image description here

First I´m using Blender Internal, cannot use Cycles because the movies used as materials on the planes do not play on OPENGL.

My problem is on the stars, they are a PNG file with a movie on the bottom, and they are getting those edges around the transparency, have tried a few things, like premultiplied and straight options on the material with no success, if I select the object on the viewport displays correct:

enter image description here

Someone knows what can I do to fix it?

$\endgroup$
  • $\begingroup$ You'd be better off doing this in the compositor. Use a Mix node with the blend mode set to Multiply. In addition to getting rid of the white edges you will also lose the specular highlights on the top of the stars, but it's a trade off. You can play with the node sliders and hopefully get an acceptable result. $\endgroup$ – Mentalist May 25 '17 at 15:16
  • $\begingroup$ I´m trying to achieve this, but I couldnt set the image as a texture on blender internal, the same way I would do it in Cycles, about the specular lights, they are not there, it´s a png image. $\endgroup$ – andrepazleal May 25 '17 at 20:18
  • $\begingroup$ I know, I didn't mean it like that. Maybe I should have said "the shiny parts of your star image". Anyway, I'm glad you got a solution. $\endgroup$ – Mentalist May 26 '17 at 13:22
2
$\begingroup$

@andrepazleal, I've had no problem placing one movie (with transparent bkd) over another and find OpenGL handles this well.

The edge effect you're describing I've also experienced and have solved that as described below...

Flame Video with transparency, stacked in front of another, all done in the 3D window by texturing planes and rendered in OpenGL -

As to the edge artifact problem, I take it that you are rendering with OpenGL and that the stars are a png file with it's own alpha layer (transparent background), being used to texture a plane.

The effect you're describing around it's edges can be the result of the plane's "Transparency" box (see below) being either ticked or unticked when in fact it needs the inverse. i.e. tick it if it's unticked and vice versa.

The edges will show when not selected and disappear when selected, just as you described. Changing it's Transparency tick should fix your problem.

If there's a plane or object behind that again, the background object's own transparency box may also affect the outcome. When the first box doesn't help you can try different combinations in both. I've experienced this problem frequently and those tick boxes have solved the issue every time.

The box is found by clicking on the plane's properties at the right, (little cube icon) going down to it's "Dipslay" tab and opening that to reveal the "Transparency" box.

You may also find that reducing a textured plane's "Specular" settings to zero, can also assist in removing artifacts.

Both Specular sliders can be found under the plane's Material properties. The main one is in the Specular tab, the other in the Transparency tab. (immediately under the Opacity slider) If both the Opacity and Specular sliders are not at dead zero, unwanted effects may occur.

The previous paragraph refers to planes being textured with an image containing an alpha (transparent) layer.

| improve this answer | |
$\endgroup$
  • $\begingroup$ What fix the whole thing for me was tick the Object\Display\Transparency option, thanks a lot mate, I can continue to use OpenGL rendering, thanks! $\endgroup$ – andrepazleal May 26 '17 at 11:08
0
$\begingroup$

A fast solution might be to actually just model a star with a 5 point circle that you subdivide the edges so you can select the 5 points and scale out, and the others scale in to get the shape to match. This way you can map the texture to the simple geo and avoid the need for alpha in such as small asset. If I understand you , the stars are a png with transparency and a movie on the bottom (actually behind) - and if the stars are not part of the movie file, then this should be a work around to avoid the white edges.

| improve this answer | |
$\endgroup$
  • $\begingroup$ To use Cycles for videos in OpenGL, you need to check the box marked 'View As Render' in the N panel in the node editor with the image texture node selected $\endgroup$ – Craig D Jones May 25 '17 at 17:37
  • $\begingroup$ I´m avoiding modelling but thanks for the suggestion in cycles id didnt work, the movie dont auto-resfresh when scrolling thru the timeline or in the OpenGL Render Animation. $\endgroup$ – andrepazleal May 25 '17 at 18:12
  • $\begingroup$ Share a screen shot or two of your cycles settings then, because here it works like a champ. $\endgroup$ – Craig D Jones May 25 '17 at 18:15
  • $\begingroup$ Ok I´ve seen what´s going on, I must have the node editor opened with the Properties tab open and also the plane with the movie material must be selected on the viewport, so it´s no possible, in this motion I have two videos so theres no way of openGL render both of them. So I think that my last choice is to model around the star and lost the soft shadow around it. $\endgroup$ – andrepazleal May 25 '17 at 20:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.