0
$\begingroup$

I have a large model of a wheelchair and I put some materials on it. I set up a sun lap and a camera, after several attempts to see my work through the camera view, there was still nothing showing in the viewer (I can see it in the 3D viewer. I scaled the camera up so that it could see the whole model and checked the clipping, but still nothing. When it enters camera view, it does not zoom straight in and look through the lens, it makes a sort of orbit into the lens which is confusing the daylights out of me. Here is a link to the blend file:

https://drive.google.com/open?id=0BxZR-5RoJhhZNndqRG96ZzhpUVE

I am a Blender beginner, please pardon my rookie stupidity.

Thank you

$\endgroup$
  • 1
    $\begingroup$ Hi, I downloaded your file (next time if possible please use this service blend-exchange.giantcowfilms.com, it will provide a link that you can paste in your question, using the edit option), and it has some scaling issue, apart that pointed out by Tak below. I will try to guide you to reset those issues later, but can you also edit your question and describe how you got that (complex) object into blender?It seems some kind of import, from another program, and this often leads to scaling/viewport/units incompatibilities. It would help all to understanda what happened here. $\endgroup$ – m.ardito May 25 '17 at 7:48
0
$\begingroup$

Here is what I see in your file that is strange (as said above, it may be due to some imported file and/or some later transform by you or others), and I'm quite sure it's causing all kind of weirdnesses you experience in your file:

enter image description here

the camera is gigantic, both in scale and size, and its location seems strange, values are too high for typical blender files.

Also you see the camera clip values are ok (default values), but the interactive view has way too big values: 1.5 and 10015 !

enter image description here

the grid, too is gigantic: 300 while the standard is 1 ?

enter image description here

and also the wheelchair (eg: the selected wheel) seems gigantic, although the scale is 1...

As you see, there is something wrong: I could correct your scene, like this: first of all, I reset "wrong" values of your grid, view, wheelchar, camera, lamp guessing they could be some hundred times higher than "normal". Where "normal" is a coherent range scale of all scene elements that makes the blender files view and manipulation (including camera view) beheve predictably, and "well".

So:

  • the wheelchair: I selected the controlling empty of all the chair elements, then I changed its location to 0,0,4 (almost grid center) and scaled it down all by 0.01 (that means 100x smaller): this makes also all the parented wheelchair elements to be transformed as the emtpy.
  • the camera: I changed its location to +30,-8,+45 and set its size back to 1, and scale to 1,1,1.
  • the lamp: I changed its location to -5,+12,+45
  • the grid: I set its size back from 300 to 1

lastly,

  • the view: I set view clip to the standard 0.1 - 1000.0 range

Now, everything seems to have disappeared! It's not, of course, its just that everything is reset to "standard" dimensions, and your view is still as previously: pressing the keyboard's "home" button (ie: "show all") should make your scene be visible again, well in the center and with proper view, grid and camera settings. And now I have this:

enter image description here

Let me know if you need to download your file corrected, but it would better that you try to repeat my steps above, so you can practice for similar situations in future.

Please don't forget to add details about how you got that file (import, transforms), if possible, because it will let a trace for other users in similar situations...

Here is the corrected file (now with a single 3d view area):

$\endgroup$
  • $\begingroup$ Thanks for all of that info. I will do my best to reproduce your steps but I still may need your corrected file for reference. I'll get back to you ASAP. Thanks! $\endgroup$ – Christina Parissi May 25 '17 at 12:44
  • $\begingroup$ @Tak Something is not right, I'm going to need the corrected file if you don't mind, things are all wonky. Maybe it's something with Blender. I am going to reset to factory settings and see if that helps. Thanks! $\endgroup$ – Christina Parissi May 25 '17 at 13:10
  • $\begingroup$ @Christina Parissi ... I'm not Tak, he added another answer.. I'm m.ardito. I added the (corrected) file at the end of this answer... $\endgroup$ – m.ardito May 25 '17 at 13:57
  • $\begingroup$ thank you for the blend file. I saw that you split the view into many frames. I moved the timeline down but now the windows aren't joining by the normal method clicking and dragging the upper corner. Sorry to be so much trouble. Di you have any ideas? $\endgroup$ – Christina Parissi May 25 '17 at 14:38
  • $\begingroup$ @Christina Parissi don't worry, although in that version of the file the windows were perfectly collapsible as usual, now I uploaded a new version of the same file, which has a single 3dview as in the default blender workspace... please download it again. $\endgroup$ – m.ardito May 25 '17 at 15:21
2
$\begingroup$

The problem is that the clipping End limit is too small. I've changed it to 6000 and it's working fine. To be able to view the clipping range you can tick the limits checkbox in the Display panel and a beam will be shown in the camera showing its clipping range as shown below:

enter image description here

Camera view:

enter image description here

$\endgroup$
  • $\begingroup$ Thank you, I had no idea the clipping would have to be such a large number! Would it have to be a large number like that if I moved the camera closer to the model? $\endgroup$ – Christina Parissi May 25 '17 at 1:24
  • $\begingroup$ @ChristinaParissi If you moved the camera closer to the model then you can decrease the clipping limit. Please accept the answer and tick as solved if it solved your problem to help future users having the same problem. $\endgroup$ – Tak May 25 '17 at 1:27
  • $\begingroup$ I don't think that is the (only) real problem... this file has also some other weird setting... $\endgroup$ – m.ardito May 25 '17 at 7:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.