6
$\begingroup$

I'm trying to make one of my first animations. It's the classic wrecking ball and tower of blocks simulation. Everything is working and I've got the camera movement in place but I'd like the physics to pause at a certain frame, let the camera move, then resume the physics.

The way I tried to accomplish this was set everything up for the animation, then when I want it paused, select all physics objects and create a keyframe to turn on Animated, then turn it back off once I'm ready to have it continue. Unfortunately when I tried to bake it, once animated turned on, nearly all the objects just disappeared, and when it came time to turn it back on, blender just froze.

$\endgroup$
  • 2
    $\begingroup$ Depending what you are doing you might want to just bake the simulation. You can then move the keyframes to make a pause $\endgroup$ – VRM May 25 '17 at 1:04
6
$\begingroup$

You can vary the speed of the physics engine via the Rigid Body World settings in the Scene properties.

rigid body world settings

Leaving the speed at 1.000 runs the simulation at 'normal time' while values closer to 0 will slow down the action.

Varying the time in this way can cause some anomalies - particularly if you change it at the point of collisions or interactions between objects. This appears to be due to issues with how the calculations are performed behind the scenes. For this reason, avoid changing the Speed right down to zero - eg, 0.002 (1/500th speed) should give reasonable results - and you will likely also need to greatly increase the Steps Per Second (I increased from 60 to 10000 - but this will take longer to calculate!) to improve the accuracy of the simulation and it might also be worthwhile toggling Split Impulse if you're getting unexpected results.

This can produce the following result :

animated

Blend file attached.

$\endgroup$
  • 1
    $\begingroup$ Thank you! This produced a very clean result without having to bake to frames. $\endgroup$ – kingfoot Jun 1 '17 at 6:05
2
$\begingroup$

Slowing down the world time does effect the simulation.

The best way to manually modify your simulation is to bake it in to keyframes. enter image description here

Then you can adjust the timing by sliding and scaling the keyframes, in the 'dope-sheet' window, until you achieve your required result.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.